Ask Your Question
0

Format error content.xml

asked 2016-04-02 16:17:44 +0200

dmb501 gravatar image

Hello all,

I realize others have asked this question, but I'm still stumped.

I'm working with an odt. document, and when I try to open it I get the following message:

Format error discovered in the file in sub-document content.xml at 2,192921(row,col)

I've used 7-zip to access the XML content, and have tried to use notepad++ [where I get an XML Parsing error: Attribute fo:background-color redefined] and I've also tried the XML copy editor [where I get a duplicate attribute error] to fix the offending content.

I'm quite concerned, because this is the 2nd document to become corrupted in the past few days, and it's never happened before.

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2017-11-27 17:37:35 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Same file corruption using libreoffice 5.0.4.2 in a debian platform. The document was converted from a docx with numerous comment and change recording activated. On the uncompressed file, I make use of vi to reach the corrupted column on line 2 of "content.xml" My reported error was on column 43490 (and also 58964) so I made use of the syntax "43490|" (number and pipe) in VI to directly point to the faulty location. I found the same fo:background-color attribute as seen by dmb500. Following the deletion of this attribute, zip re-compression and odt renaming of the extension, I recovered the original data. JP

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-04-02 16:17:44 +0200

Seen: 593 times

Last updated: Nov 27 '17