Ask Your Question
0

Spreadsheet cell clipboard

asked 2016-04-03 19:27:06 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

When you copy a cell, let's say A1, with Ctrl-C it gets a dotted line around it. Then it can be pasted into another cell with Cntrl-V. OK, that is expected.

BUT!!!

If you choose another cell, let's say C4, with or without data in it, and press ENTER, the contents of the clipboard is emptied into that cell (C4), overwriting it without asking for confirmation, that it's okay to overwrite it.

I'm using ENTER to edit the cells, so this function is a catastrophe! Is there no way to disable it? I have searched all the settings and found none.

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2016-04-04 13:52:49 +0200

Lupp gravatar image

Hit Ctrl+Z if there was pasted something against your will.

edit flag offensive delete link more

Comments

This is the best workaround at present. There was a change in behaviour back between v3.3 and v3.4 with respect to the ENTER key that affected general navigation/editing using TAB/ENTER. Refer tdf#58929.

oweng gravatar imageoweng ( 2016-04-04 14:27:06 +0200 )edit
0

answered 2016-04-04 07:08:57 +0200

meolar gravatar image

updated 2016-04-04 07:10:14 +0200

I don't know how to change the default, but try hitting the ESCAPE key after you hit CTRL-c.

It will get rid of the dotted line around A1 then and ENTER will not empty the clipboard into another selected cell.

edit flag offensive delete link more
0

answered 2016-04-04 12:03:54 +0200

Jens S gravatar image

If you don't like this Excel circumcision - go to Function - Tools - LibreOffice Calc - Compatibility and change the key bindings to 'OpenOffice'

Jens

edit flag offensive delete link more

Comments

Also a possible workaround, but OOo keybindings are ... old.

oweng gravatar imageoweng ( 2016-04-04 14:29:04 +0200 )edit

I tried it and it works! OOo keybindings might be old, but the only other way to get around this "feature" is to run OOo itself. Thankk you very much!

BugOr Feature gravatar imageBugOr Feature ( 2016-04-05 21:28:19 +0200 )edit
0

answered 2016-04-03 23:38:17 +0200

m.a.riosv gravatar image

It's an option enable the confirmation for overwrite.

Menu/Tools/Options/LibreOffice calc/General - Show overwrite warning when pasting data.

edit flag offensive delete link more

Comments

Works good when pasting with Ctrl-V, but NOT when pressing ENTER!

BugOr Feature gravatar imageBugOr Feature ( 2016-04-04 06:31:18 +0200 )edit

Yes. Old bug: tdf#47490.

oweng gravatar imageoweng ( 2016-04-04 14:20:35 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-04-03 19:27:06 +0200

Seen: 106 times

Last updated: Apr 04 '16