Spreadsheet cell clipboard

When you copy a cell, let’s say A1, with Ctrl-C it gets a dotted line around it. Then it can be pasted into another cell with Cntrl-V. OK, that is expected.


If you choose another cell, let’s say C4, with or without data in it, and press ENTER, the contents of the clipboard is emptied into that cell (C4), overwriting it without asking for confirmation, that it’s okay to overwrite it.

I’m using ENTER to edit the cells, so this function is a catastrophe! Is there no way to disable it? I have searched all the settings and found none.

Hit Ctrl+Z if there was pasted something against your will.

This is the best workaround at present. There was a change in behaviour back between v3.3 and v3.4 with respect to the ENTER key that affected general navigation/editing using TAB/ENTER. Refer tdf#58929.

It’s an option enable the confirmation for overwrite.

Menu/Tools/Options/LibreOffice calc/General - Show overwrite warning when pasting data.

Works good when pasting with Ctrl-V, but NOT when pressing ENTER!

Yes. Old bug: tdf#47490.

I don’t know how to change the default, but try hitting the ESCAPE key after you hit CTRL-c.

It will get rid of the dotted line around A1 then and ENTER will not empty the clipboard into another selected cell.

If you don’t like this Excel circumcision - go to Function - Tools - LibreOffice Calc - Compatibility and change the key bindings to ‘OpenOffice’


Also a possible workaround, but OOo keybindings are … old.

I tried it and it works! OOo keybindings might be old, but the only other way to get around this “feature” is to run OOo itself. Thankk you very much!