Ask Your Question
2

Change default paper size won't stick [closed]

asked 2012-10-16 05:21:33 +0100

Miles gravatar image

updated 2015-10-19 00:38:43 +0100

Alex Kemp gravatar image

Using Libre Office Writer 3.6.2.2 with Win7, 64bit. Cannot change default page size from letter to A4. Have gone to format/page and change it there, but it always reverts to Letter as default when the next doc is opened. Also tried Format/Styles and added style A4 which also doesn't stick. Using printer Canon MG5370 which is set for A4 and contains that paper size.

What is the trick to changing the default paper size?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-19 00:38:27.151259

4 Answers

Sort by » oldest newest most voted
0

answered 2012-11-06 11:40:23 +0100

cloph gravatar image

Some additional info/alternative way to change the page format.

LibreOffice takes them from the system's regional settings, but you can tell LibreOffice otherwise by going to Tools | Options → Language Settings → Languages

Choose a suitable value for Locale Settings, i.e. pick a code for a region where the desired format is used. "English (USA)" has letter size, but "English (UK)" has A4 format for example. But changing the Locale Settings will also set the default language of the document to the chosen value, and also use the region's date and time formats. This might be the desired outcome, maybe not. So what way to choose (custom document template or changing locale/regional settings) depends on the circumstances.

edit flag offensive delete link more

Comments

Thanks, and UK would be fine except the spell check would differ a great deal from USA.

Miles gravatar imageMiles ( 2012-11-14 13:41:37 +0100 )edit

Hmmm... Doesn't seem to work as expected. I am trying to go the other way on this one; A4 to Letter as the default and it keeps reverting back to A4. Checked the Locale settings and it was already set to "Default - English (USA)". I even tried setting it explicitly to "English (USA)" and it still comes up as A4 as the default. Guess I need to use the Template trick below.

EDIT: I got it... Not the Locale Settings, but changing the User Interface did the trick.

B.Kaatz gravatar imageB.Kaatz ( 2013-09-20 19:22:01 +0100 )edit

I have tried the above suggestion and it is still A4 as opposed to leter...

kcallis gravatar imagekcallis ( 2014-10-01 14:32:50 +0100 )edit
2

answered 2012-10-18 17:59:41 +0100

jeanweber gravatar image

Create a template from an A4 document, then make that template the default template for Writer. See Chapter 3 of the Getting Started guide, http://wiki.documentfoundation.org/Documentation/Publications#Getting_Started_with_LibreOffice

edit flag offensive delete link more

Comments

Have created a couple of templates which are working fine -- one as a basic document A4 size and another also A4, letterhead with a 1" margin on all 4 sides. The only difficulty I have -- or perhaps lack of understanding is that if either one of these is saved as .txt and opened in Libre using File

Miles gravatar imageMiles ( 2012-11-13 21:20:42 +0100 )edit

I surely do wish I could understand why it is so difficult. The locale for me is USA, but LibreOffice is amazingly insistent upon using A4 anyway. The "then make that template the default template" step is beyond non-obvious. Searching the linked-to doc for "paper size" should lead me to paper size selection, but I only get paper size mismatch error selection. Google searches have YEARS of history of people with this problem. Why isn't the fix made easy?

BruceK gravatar imageBruceK ( 2013-08-16 19:56:27 +0100 )edit
0

answered 2012-11-06 07:35:21 +0100

Miles gravatar image

Thank you and I've finally had time to set up a few templates. Had a devil of a time getting the page size to stick -- changing from Letter to A4, but finally worked that out.

edit flag offensive delete link more
0

answered 2012-11-13 21:22:45 +0100

Miles gravatar image

Have created a couple of templates which are working fine -- one as a basic document A4 size and another also A4, letterhead with a 1" margin on all 4 sides. The only difficulty I have -- or perhaps lack of understanding is that if either one of these is saved as .txt and opened in Libre using File/Recent Docs it loses the template format and apparently opens in the default format. If saved as .rtf and opened using file/recent docs apparently it opens in the template format as it should. Does this mean a doc should not be saved as .txt and should always be saved as .rtf or .doc or such?

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-10-16 05:21:33 +0100

Seen: 20,288 times

Last updated: Nov 13 '12