Ask Your Question

LO 5.1 GLIBC minimum version (

asked 2016-05-05 19:21:52 +0200

Bart2000 gravatar image


I just installed LO on RH EL5 x64 and it will not run. It is complaining at start up that GLIBC_2.7 is not available. This was not in the RPM as an install requirement. I had 5.05 installed and running before removing it and installing

The system requirements still list "glibc2 version 2.5 or higher" EL 5 is at glibc 2.5. Is this a LO build issue or is this a new requirement?

/opt/libreoffice5.1/program/oosplash: /lib64/ version `GLIBC_2.7' not found (required by /opt/libreoffice5.1/program/oosplash)
/opt/libreoffice5.1/program/oosplash: /usr/lib64/ version `GLIBCXX_3.4.9' not found (required by /opt/libreoffice5.1/program/
/opt/libreoffice5.1/program/oosplash: /usr/lib64/ version `GLIBCXX_3.4.10' not found (required by /opt/libreoffice5.1/program/

Thank you.

edit retag flag offensive close merge delete


I Also Tried 5.2 alpha and I see the same problem.
5.0.6 works as expected.

Bart2000 gravatar imageBart2000 ( 2016-05-05 19:36:24 +0200 )edit


Could you please tell me which exact version of LO5.0.6 worked for you. I am also trying to achieve this with LO6.0 and getting the same error mentioned above

Keerthi gravatar imageKeerthi ( 2018-04-09 14:40:24 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2016-05-06 05:45:52 +0200

oweng gravatar image

updated 2016-05-06 05:47:48 +0200

I cannot address your specific (RHEL) issue, however it would appear that with LO v5.1 the release notes indicate a raising of the glibc baseline to v2.12 for Cent OS 6. This currently appears to disagree with what is stated on the system requirements page for GNU/Linux:

glibc2 version 2.5 or higher

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2016-05-05 19:21:52 +0200

Seen: 399 times

Last updated: May 06 '16