LO 5.1 GLIBC minimum version (


I just installed LO on RH EL5 x64 and it will not run. It is complaining at start up that GLIBC_2.7 is not available. This was not in the RPM as an install requirement. I had 5.05 installed and running before removing it and installing

The system requirements still list “glibc2 version 2.5 or higher” EL 5 is at glibc 2.5.
Is this a LO build issue or is this a new requirement?

/opt/libreoffice5.1/program/oosplash: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by /opt/libreoffice5.1/program/oosplash)
/opt/libreoffice5.1/program/oosplash: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /opt/libreoffice5.1/program/libuno_sal.so.3)
/opt/libreoffice5.1/program/oosplash: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by /opt/libreoffice5.1/program/libuno_sal.so.3)

Thank you.

I Also Tried 5.2 alpha and I see the same problem.
5.0.6 works as expected.


Could you please tell me which exact version of LO5.0.6 worked for you. I am also trying to achieve this with LO6.0 and getting the same error mentioned above

I cannot address your specific (RHEL) issue, however it would appear that with LO v5.1 the release notes indicate a raising of the glibc baseline to v2.12 for Cent OS 6. This currently appears to disagree with what is stated on the system requirements page for GNU/Linux:

glibc2 version 2.5 or higher