Ask Your Question
0

Keep getting error "JRE Required"

asked 2016-06-09 17:21:26 +0200

Martos gravatar image

In Base, I keep getting an error "JRE Required" "LO requires a Java runtime environment (JRE) to perform this task..." I've tried installing latest versions of Java, and Apple's deprecated version.

Macbook Pro 2.5 GZ Core i7 running OS X 10.11.5 LO Version: 5.0.6.3 Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa Terminal says java version "1.6.0_65" Java(TM) SE Runtime Environment (build 1.6.0_65-b14-468-11M4833) Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-468, mixed mode)

I also tried LO V 5.1.3 with same issue.

I'd appreciate any pointers to resolve this issue...

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-06-11 15:35:47 +0200

EdwinK gravatar image

Still not working.

MacBook / OSx Sierra LO : Version: 4.3.7.2 Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba

Tried both JRE 8 AND JDK 8 several times. No luck. Really this should be more easier to fix

edit flag offensive delete link more

Comments

There are a couple of possibilities. 32-bit LO requires 32-bit JDK & 64-bit LO requires 64-bit JDK. Make sure the correct JDK is installed for your Mac. Also, under Libreoffice->Preferences the LibreOffice-Advanced selection, make sure Use a Java runtime environment is selected.

Ratslinger gravatar imageRatslinger ( 2017-06-11 16:25:12 +0200 )edit

LO on macOS supports only 64-bit, and the JDK and JRE that I installed are both 64-bit. Also, as I said in my original post, I did select the "Use a Java runtime environment". Your reply is not helpful.

BillLibre gravatar imageBillLibre ( 2017-09-26 16:57:25 +0200 )edit

@BillLibre Sorry my comment wasn't helpful to you but it wasn't in direct answer to your question. In fact the answer was months prior to your question even being posted. I have now seen mixed results regarding OSX 10.12.x and if you are not able to get you system working I suggest you either report it as a new bug or possibly it may be part of Bug #112551.

Ratslinger gravatar imageRatslinger ( 2017-09-26 17:50:42 +0200 )edit
0

answered 2016-06-09 18:02:23 +0200

Martos gravatar image

Resolved the issue by installing JDK jdk-8u91-macosx-x64.dmg

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-06-09 17:21:26 +0200

Seen: 507 times

Last updated: Jun 11 '17