Keep getting error "JRE Required"

In Base, I keep getting an error “JRE Required” “LO requires a Java runtime environment (JRE) to perform this task…” I’ve tried installing latest versions of Java, and Apple’s deprecated version.

Macbook Pro 2.5 GZ Core i7 running OS X 10.11.5
LO Version: Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Terminal says
java version “1.6.0_65”
Java™ SE Runtime Environment (build 1.6.0_65-b14-468-11M4833)
Java HotSpot™ 64-Bit Server VM (build 20.65-b04-468, mixed mode)

I also tried LO V 5.1.3 with same issue.

I’d appreciate any pointers to resolve this issue…

Resolved the issue by installing JDK jdk-8u91-macosx-x64.dmg

Still not working.

MacBook / OSx Sierra
LO : Version:
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba

Tried both JRE 8 AND JDK 8 several times. No luck. Really this should be more easier to fix

There are a couple of possibilities. 32-bit LO requires 32-bit JDK & 64-bit LO requires 64-bit JDK. Make sure the correct JDK is installed for your Mac. Also, under Libreoffice->Preferences the LibreOffice-Advanced selection, make sure Use a Java runtime environment is selected.

LO on macOS supports only 64-bit, and the JDK and JRE that I installed are both 64-bit. Also, as I said in my original post, I did select the “Use a Java runtime environment”. Your reply is not helpful.

@BillLibre Sorry my comment wasn’t helpful to you but it wasn’t in direct answer to your question. In fact the answer was months prior to your question even being posted. I have now seen mixed results regarding OSX 10.12.x and if you are not able to get you system working I suggest you either report it as a new bug or possibly it may be part of Bug #112551.