Ask Your Question
0

How do I make Spellchecker use the Canadian version of English?

asked 2016-06-16 23:18:38 +0200

ssum gravatar image

updated 2016-06-17 02:55:14 +0200

I have Libre Office 5.1.3.2

The Spellchecker does not seem to work for Canadian English and perhaps for USA (not thoroughly checked out).


Under Tools\Options\Language settings\Languages\:

                       \Language of\ :
 User interface:    [Default - English (USA)]
 Locale setting:    [English (Canada)]
 Default currency:  [Default - CAD]

                      \Default languages for documents\:
 Western:            [ABC English (Canada)]

"For current document only" IS NOT CHECKED.


Under Tools\Options\Language settings\Writing Aids\:

 Available language modules: 
 [-/] Hunspell checker
 [all other boxes also checked]]

 User-defined dictionaries:  
 [-/] Standard (English UK)
 [-/] en-GB (English USA)
 [-/] en-US (All)
 [-/] technical (all) 
 [-/] IngnoreAlLlist (All) 

 Options: 
 [-/] Check spelling as you type
 [all other boxes also checked except:]
 [ ] Check words with numbers
 [ ] Hyphenate without inquiry

Under Tools\Options\Language settings\English sentence checking\:

No "Grammar checking" [boxes] are checked.

Two "Punctuation" boxes are checked.

 [-/] Word spacing   
 [-/]Multiplication sign

No "Others" [boxes] are checked.


Under \Tools\Extension manager\

..at the topthere is "English spelling dictionary, hyphenation rules, thesaurus and grammar checker" [lock icon]

When I click on "Options" for this extension....

Under Language settings:

it only offers "English sentence checking"

It does not offer "Languages" or "Writing aids".


Under \Tools\Spelling and grammar\

Text language: [None]

I am unable to choose a text language; nothing sticks or even shows when chosen from the list.


Under \Format\character\Language:

I can choose: [English (Canada)]

...and it shows in the status bar at the bottom of the editing page but it does not `stick', that is, when I close the document and reopen Libre Office it is gone.

....it does nothing apparent, certainly not Libre-ate the SpellChecker!


An imported odt document did do automatic spell checking until I tried to enable this feature In a fresh Libre Office- created odt document.

Now no documents spellcheck when writing or when asked through \Tools\Spelling and grammar.

I don't know if it can from OO or LO and if USA spellchecking was enabled in the program.

What might be wrong?

Thanks.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2016-06-21 06:55:06 +0200

ssum gravatar image

updated 2016-06-21 06:57:28 +0200

Thanks for your response. Writing a word with Canadian spelling and checking Character\Format\Character, All English variants were there. Following this made me review \Tools\Language and seeing the choices of, Selection, Paragraph or All Text, I chose All Text\English (Canada). This changed the spelling for the document I was testing that had been confusing matters. That had been a puzzle and still is (how it became an exception) but fresh documents had at this time been cooperating.

I did not install the English Language Pack (or rather as best as I recall I installed then uninstalled it and it is now not installed). The first entry in \Tools\Extension Manager is `English spelling dictionaries, Hyphenation notes, thesaurus (etc.)'.

How do I "tick" a correct answer?

edit flag offensive delete link more

Comments

To the left of question/answers you have vertical angle brackets above and below the score for the question/answer: these can be used to vote on the value of the question/answer. Below, only for answers, there is a grey check mark. When you click it, it turns green to denote an "approved" answer.

ajlittoz gravatar imageajlittoz ( 2016-06-21 08:08:47 +0200 )edit
0

answered 2016-06-17 07:58:51 +0200

ajlittoz gravatar image

You did not tell if you installed the English language pack. LO "from the box" only contains English (USA).

One way to ckeck LO language capabilities is to try to set the language for a word.

Click Format->Character, Font tab. There is a Language drop-down menu. Installed languages have a blue check mark with ABC.

If only English (USA) is ticked (no other English variants), install the English language pack. Method varies with OS/distribution but it is rather straightforward.

If you think this is a correct answer, please tick it for community benefit.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-06-16 23:18:38 +0200

Seen: 848 times

Last updated: Jun 21 '16