Ask Your Question
0

How do I get Base to work in Windows 10 64bit

asked 2016-06-20 01:28:18 +0200

amoht gravatar image

Base says JRE is defective in Windows 10 64bit. Latest version of JRE was downloaded an installed. Oracle says is suitable for 32 and 64 bit Windows 10.

edit retag flag offensive close merge delete

Comments

Are you using 32 or 64 bit LO?

As you stated below JDK, which contains JRE, will not help and is over double the size.

timelord gravatar imagetimelord ( 2016-06-23 12:22:36 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2016-06-21 08:52:36 +0200

jay Arr gravatar image

updated 2016-06-24 08:53:07 +0200

You don't say which version of LibreOffice you are using.

If you are using LO 5.* and Base the best advice is to install the latest JDK (Java Development Kit) rather than the JRE.

You ask why JDK rather than JRE: see this answer and this answer

edit flag offensive delete link more

Comments

Hi jay Arr

Why JDK rather than JRE?

Regards

timelord gravatar imagetimelord ( 2016-06-21 10:47:56 +0200 )edit

I am using LO 5. I will try your suggestion to use JDK.

Regards

amoht gravatar imageamoht ( 2016-06-23 00:29:47 +0200 )edit

The Oracle site says " The JDK is a development environment for building applications, applets, and components using the Java programming language" so I can't see that JDK would help. Some answers I have seen to similar questions say to install the java version for 32 bit Windows. but I can't find such a version for Windows 10. The only version is one which Oracle says is suitable for 32 and 64 bit Windows 10.

Regards

amoht gravatar imageamoht ( 2016-06-23 01:09:23 +0200 )edit

Thank you jay Arr

I was aware of the previous Q & A's

timelord gravatar imagetimelord ( 2016-06-24 10:09:33 +0200 )edit
0

answered 2016-06-24 15:18:31 +0200

Ratslinger gravatar image

updated 2016-06-24 15:34:17 +0200

I'm no expert on this issue but I'll relay my understanding thus far.

Lo Base requires the installation of JRE. The version used should be of the same bit size - 32 bit LO and 32 bit JRE; 64 bit LO and 64 bit JRE.

The exception to this is for Mac as reported here. See the bug reports mentioned.

In a previous post as noted by @jay Arr I was most likely wrong. I found a post (since lost) regarding Java libraries. I cannot substantiate my answer there.

Now most of the problems I see are related to either Mac or Windows (mostly Win 10). I have not verified this (don't use Windows anymore), but this post mentions installation of 32 bit JRE using a 64 bit Win LO worked for the Base problem.

So, in answer to @amoht, if willing to try, the 32 bit JRE is located here (Windows x86).

Edit: changed OS to LO. My apologies.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-06-20 01:28:18 +0200

Seen: 4,303 times

Last updated: Jun 24 '16