Ask Your Question
0

[“Writer”:] AutoCorrect sentence case does not seem to function

asked 2016-08-04 18:51:53 +0200

The Writer gravatar image

Dear reader,

As far as I can determine, on my system [UbuntuGNOME 15.04 64-bit; LibreOffice Version: 4.4.6.3, Build ID: 40m0(Build:3), Locale: en_US.UTF-8] the Writer AutoCorrect Option to “Capitalize first letter of every sentence” doesn't work, although both boxes “[M]: Replace while modifying existing text” and “[T]: AutoCorrect while typing” are checked (as default, as far as I'm aware). I would be grateful for any pointers to possible causes and, even better, solutions for my 'problem' that Writer does not capitalize the first letter of every sentence despite these settings.

Many thanks in advance...

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2016-08-05 15:08:11 +0200

The Writer gravatar image

Yes, "...[w]hile typing" is checked (as I already mentioned in my OP).

edit flag offensive delete link more

Comments

Little misunderstanding: it seemed to me that you referred to the two columns in the options for autocorrect, marked with [M] and [T], but I was referring to the menu item Tools - Autocorrect - While typing. You should not only tick all items that you want to be covered by autocorrect, but you also have to tell Libre that you want autocorrect at all.

floris v gravatar imagefloris v ( 2016-08-05 21:39:31 +0200 )edit
0

answered 2016-08-06 14:21:21 +0200

RGB-es gravatar image

It fails for every sentence or just in some cases? See for example this report:

https://bugs.documentfoundation.org/s...

edit flag offensive delete link more
0

answered 2018-05-22 02:34:19 +0200

bblack4jc gravatar image

I know this is an old post, but perhaps, like myself, someone may come across it looking for the answer. The problem I had was with libre office writer. The spell check was not capitalizing the first letter of the first word of the sentence.

Solution: Open up Writer. Go to Tools - go to the bottom and choose "Options." On the left-hand side go down to "Language Settings" and click on the +. This will open up a sub-menu. Click on "English Sentence Checking". To the right in the blue section you will see "Grammar Checking". Click on the box before "Capitalization" and any other boxes you choose. Click the OK button at the bottom. The screen will close and you will be back to your document. Save your document. Close it out. Reopen your document and go to Tools - Spelling and Grammar. It should now catch all of those beginning small letters.

edit flag offensive delete link more

Comments

That only works for English text.

floris v gravatar imagefloris v ( 2018-05-22 16:11:08 +0200 )edit
0

answered 2016-08-04 19:04:36 +0200

floris v gravatar image

Make sure that Tools - Autocorrect > While typing is checked. Does autocorrect work at all?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-04 18:51:53 +0200

Seen: 133 times

Last updated: May 22 '18