[“Writer”:] AutoCorrect sentence case does not seem to function

Dear reader,

As far as I can determine, on my system [UbuntuGNOME 15.04 64-bit; LibreOffice Version:, Build ID: 40m0(Build:3), Locale: en_US.UTF-8] the Writer AutoCorrect Option to “Capitalize first letter of every sentence” doesn’t work, although both boxes “[M]: Replace while modifying existing text” and “[T]: AutoCorrect while typing” are checked (as default, as far as I’m aware). I would be grateful for any pointers to possible causes and, even better, solutions for my ‘problem’ that Writer does not capitalize the first letter of every sentence despite these settings.

Many thanks in advance…

Make sure that Tools - Autocorrect > While typing is checked. Does autocorrect work at all?

Yes, “…[w]hile typing” is checked (as I already mentioned in my OP).

Little misunderstanding: it seemed to me that you referred to the two columns in the options for autocorrect, marked with [M] and [T], but I was referring to the menu item Tools - Autocorrect - While typing. You should not only tick all items that you want to be covered by autocorrect, but you also have to tell Libre that you want autocorrect at all.

It fails for every sentence or just in some cases? See for example this report:


I know this is an old post, but perhaps, like myself, someone may come across it looking for the answer. The problem I had was with libre office writer. The spell check was not capitalizing the first letter of the first word of the sentence.

Solution: Open up Writer. Go to Tools - go to the bottom and choose “Options.”
On the left-hand side go down to “Language Settings” and click on the +. This will open up a sub-menu.
Click on “English Sentence Checking”. To the right in the blue section you will see “Grammar Checking”.
Click on the box before “Capitalization” and any other boxes you choose.
Click the OK button at the bottom. The screen will close and you will be back to your document.
Save your document.
Close it out.
Reopen your document and go to Tools - Spelling and Grammar.
It should now catch all of those beginning small letters.

That only works for English text.