Ask Your Question
1

Format Paintbrush - formats too much text [closed]

asked 2012-11-06 09:56:37 +0200

anonymous user

Anonymous

updated 2015-10-21 01:52:12 +0200

Alex Kemp gravatar image

Using LibreOffice Writer 3.6.3.2 on Windows XP sp3.

  1. Open new Writer document.
  2. In first line use default font "Times New Roman" and type in: one two three
  3. Press Enter. In second line type: four six seven.
  4. Select text in line two and change font to Courier New.
  5. Press End key to un-select the text and press Enter to move to third line.
  6. Don't select anything just change font to Times New Roman, so next typed text will be in this new selected font.
  7. In third line type in: eight nine ten
  8. Select "five" (which is using font Courier New) from second line and click on Format Paintbrush.
  9. Select word nine (which is currently using Times New Roman) and release mouse button.

What happens? Whole third line: "eight nine ten" gets new font Courier New, but I would only like to change the font to selected area only in my case word nine.

Is this a bug in Format Paintbrush or does it work as designed? Is there any way I can format only the text copied?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-21 01:52:26.605680

1 Answer

Sort by » oldest newest most voted
1

answered 2012-11-07 01:24:06 +0200

m.a.riosv gravatar image

I think we can find an explanation:

Select second line and press Ctrl-M to reset default, select five and select courier font, click the format paintbrush, select nine. Only nine changes.

Why, in your sample you are selecting the line (=paragraph), before change the font, this change the paragraph font, while in my sample the font is applied only to one character, changing only the character font.

Paintbrush seems works as expected, if there is a character format/style copy character format otherwise copy the paragraph format/style.

edit flag offensive delete link more

Comments

Thanks now I understand the logic. There are "paragraph" and "character" format-paintbrush. Like I see the real work-around is to left whole second line in Courier New and just move cursor to the end of second line (after last character in line) and press CTRL+M. Now formatting works fine.

L-user gravatar imageL-user ( 2012-11-07 08:46:36 +0200 )edit

Question Tools

Stats

Asked: 2012-11-06 09:56:37 +0200

Seen: 294 times

Last updated: Feb 01 '13