Ask Your Question
0

Copy text from writer w/o hidden characters

asked 2016-08-31 23:40:43 +0200

Dor gravatar image

I have LibreOffice Writer version 5.1.

I have a Writer document which contains code.
That document is exported to PDF.

Sometimes I wish to copy the code from the PDF but it contains hidden chars which cause problems.
How do I create in Writer a paragraph which contains only clear text (no hidden chars or any other weird stuff) ??

("chars" means "characters".)

edit retag flag offensive close merge delete

Comments

1

What characters? Could you edit your question and copy them to it? It's always easier when you have an example, now it's not very hard to figure it out. Can you delete those extra characters from Writer?

Kruno gravatar imageKruno ( 2016-09-01 08:55:23 +0200 )edit

@Kruno: I can't edit my post :-/. I've copied the text from the PDF to a plain text file and saved it. Then I used the program xxd and found that the first characters' hex value is: e280 abe2 80aa (These chars show prior to the first legitimate char). These characters are "RIGHT-TO-LEFT EMBEDDING" and "LEFT-TO-RIGHT EMBEDDING" in UTF8 encoding. Additional similar chars appear between the words (wherever a space exists). Example of additional sequence: E2 80 AC.

Dor gravatar imageDor ( 2016-09-01 11:00:59 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-09-01 10:58:49 +0200

Kees538 gravatar image

updated 2016-09-01 11:10:02 +0200

Kruno gravatar image

Select your text and choose 'copy'. Then go to Writer. Right click and choose Paste special > Unformatted text.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-31 23:40:43 +0200

Seen: 103 times

Last updated: Sep 01 '16