Ask Your Question
1

Spell check doesn't work

asked 2016-11-22 07:16:10 +0200

jharpj gravatar image

updated 2020-08-03 00:24:10 +0200

Alex Kemp gravatar image

Spell check doesn't work. I get a check mark for English USA but not Paragraph or for all text. The spell checker still doesn't work although when I start a sentence with a lower case letter it corrects it.

edit retag flag offensive close merge delete

Comments

Have you checked in Tools->Options ..., Language Settings->Writing Aids that the modules, dictionaries and desired options are enabled?

ajlittoz gravatar imageajlittoz ( 2016-11-22 08:07:33 +0200 )edit

Please provide more information for questions like this. Like: has it worked before but is this a sudden change in behavior of Libre, or have you just installed it and doesn't it work out of the box, like that. If you are completely new to LibreOffice, you don't need to reset the user profile as in my answer.

floris v gravatar imagefloris v ( 2016-11-22 09:14:25 +0200 )edit

Mine did not work. I downloaded the extension for English (USA) which was part of the latest bundle and installed the bundle and I think I added English (USA) to my dictionaries. Still it did not work. I searched here and found all the options suggested in the other answers were checked already including hunspell. So then I changed from the default English USA to this one I had downloaded in the Options > Language Settings > Languages > Default Languages for Documents. Then after Libre Office restarted, it worked.

Stephen Mikesell gravatar imageStephen Mikesell ( 2019-04-24 21:36:04 +0200 )edit

I had to make sure LibreOffice knew my text was English. Select all text, right click > Styles > Edit Style. Click the Font tab. Don't change the font, just change the language to "English (USA)"

You can make this automatic for new documents in the Options menu, as Stephen Mikesell notes above.

jeifjei gravatar imagejeifjei ( 2019-10-03 22:11:25 +0200 )edit

This Worked! My LibreOffice had been working great for years, then suddenly the spell checker just gave me blank forms. I did the "Writing Aids" but it didn't help me. The "Default Languages" was set to German. I don't know how that happened, but I speak English (American Southern Style!). That change fixed it. THANK YOU!

scottdp3 gravatar imagescottdp3 ( 2020-12-14 22:33:27 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2016-11-22 09:09:19 +0200

floris v gravatar image

updated 2016-11-25 09:38:37 +0200

Reset your user profile. See https://wiki.documentfoundation.org/F... - important: rename the folder, don't delete it. Resetting the user profile solves many problems.

You have to assign a language to your text, or the spell checker won't work. You can do that in tools - Options - Language settings - Languages - Default Languages for Documents. But you cal also modify the Default paragraph style, select the Font tab and select a language there.

Please note that the spell checker doesn't automatically correct any errors, it just highlights them. Lowercase changing to uppercase is Autocorrect's work. Take a look at Tools - Autocorrect - Autocorrect options to see what it will do for you (and disable anything that you don't like).

EDIT: Make sure that hunspell is also ticked, that's the actual spell checking module. There's a bug in Apache OpenOffice, and maybe in Libre as well, that messes up spell checking for files created in Windows Explorer (the file manager, not the Internet browser). Can you get the spell checking to work in files created within Writer? If you can, upload a sample file for testing purposes.

image description

You can also try Tutorial Spell check and Language configuration - and check in at that forum to get more help. When you register, you need to provide a (fake) version of OpenOffice that you use, a trick to defeat spam bots.

edit flag offensive delete link more

Comments

Spelling doesn't correct files created by LO or MSO. I can't find "Hunspell" or instructions regarding it - so can't see if it's ticked. Maybe somebody will tell me?

jharpj gravatar imagejharpj ( 2016-11-25 01:22:57 +0200 )edit

Tools>Language Settings>Writing Aids should show 3 Boxes. The top one "Available language modules:" should show as in the picture from @floris v. This shows "Hunspell".

peterwt gravatar imagepeterwt ( 2016-11-26 19:53:43 +0200 )edit

When I go to >Options - Language Settings - Writing Aids< the only module shown is "Lightproof grammar checker (English)

Hunspell is not there under Writing aids or anywhere elsse.Lacking any further instructions on how to install Hunspell into the list I guess that I am to select Edit - get more dictionaries online but find I am unable to find Hunspell. Please tell how to find and install Hunspell . . . .Thanks.

jharpj gravatar imagejharpj ( 2016-11-27 15:12:14 +0200 )edit

You have to run the install program for LibreOffice again. This is a serious failure. Did you download the program from the official site?

floris v gravatar imagefloris v ( 2016-11-27 21:18:02 +0200 )edit

I deleted the previous version of LO and installed a new one - nothing has changed. Both downloads were from www.Libreoffice.org/download

jharpj gravatar imagejharpj ( 2016-11-28 04:41:00 +0200 )edit

Still no hunspell module? It seems to me that direct access to your computer is necessary to solve this. That means: ask a friend who is more comfortable with computers than you are to sort this out. Questions can be asked at http://forum.openoffice.org/en/forum/ (easier comnnumication than here, for registration you have to add a (phoney) version of OpenOffice).

floris v gravatar imagefloris v ( 2016-11-28 10:44:02 +0200 )edit

Problem solved.

Early on in this session I was advised that changing the user profile was not necessary. Well guess what? It was - and it seems to have fixed my spellcheck problem. Thank you very much for your time and interest in solving this.

jharpj gravatar imagejharpj ( 2016-11-30 16:55:56 +0200 )edit

I supposed that if this was the first time ever that you installed LibreOffice, the user profile couldn't be corrupted yet. But apparently it can. How long have you had LibreOffice?

floris v gravatar imagefloris v ( 2016-11-30 17:14:20 +0200 )edit

Since 11/5/2016 And now with the spell check working I am a happy camper. .

jharpj gravatar imagejharpj ( 2016-11-30 21:02:54 +0200 )edit

Okay, that's long enough for it to get corrupted. Pity I thought you had just downloaded and installed it. Glad it's solved. :)

floris v gravatar imagefloris v ( 2016-11-30 21:45:40 +0200 )edit
0

answered 2020-07-10 21:24:46 +0200

studog gravatar image

In my case, all of the above tips checked out as "working". Safe Mode showed the problem wasn't with my profile, the Language Options were set correctly.

It turns out that my specific problem was that I'd selected Canadian English as my default language, but sudo apt policy hunspell-en-* indicated that only the US English dictionary was installed. sudo apt install hunspell-en-ca fixed my problem. I restarted Libre Office Write after installing the dictionary just in case, I'm not sure if that step was needed or not.

This problem was particularly vexing because the spell check claimed to be working but never flagged any of the purposefully wrongly spelled test words so very clearly wasn't working. Just "Spell check complete" every time. As a programmer, functionality should never fail and be able to claim success.

I'm not sure how my system got into this situation, but I have a theory. I wiped and reinstalled from scratch Ubuntu 18.04 a few months ago. Then I restored various data from backup, including a number of spreadsheets and documents. I suspect that on my pre-wipe system, when I set Canadian English, it auto-installed the proper dictionary. When I opened an old document on my post-wipe system, the old settings in the document were used to update my new fresh profile, but the proper dictionary install step was not done.

Posted in case this helps someone else.

edit flag offensive delete link more

Comments

It is not clear if language for your documents was properly set (in addition to install the proper dictionary). Defining the default language is done in Tools>Options, Language Settings>Languages.

ajlittoz gravatar imageajlittoz ( 2020-07-11 08:02:52 +0200 )edit

I said above "the Language Options were set correctly".

Language Settings -> Languages -> Default Languages for Documents -> Western == Default - English (Canada)

studog gravatar imagestudog ( 2020-07-15 18:07:55 +0200 )edit

Thank you studog. You solved my problem! I had the exact same issue and could not figure out what was wrong. Changing settings had no effect at all, but once I installed hunspell-en-ca everything worked properly. I agree that the absence of any warnings or error messages makes the problem especially confusing.

rdbat gravatar imagerdbat ( 2020-11-11 23:50:56 +0200 )edit
0

answered 2016-11-22 16:35:13 +0200

jharpj gravatar image

updated 2016-11-22 16:43:16 +0200

I am a new user who has poured over the questions and answers with no success.

LO version 5.2.3.3 MS Windows 10 with current updates. The spell checker never worked except once there appeared a squiggly line under a word but it wouldn't give me a suggestion and has never done it again. Typing a sentence with obvious errors then selecting "Tools/Spelling and Grammar" results the message: "Spellcheck is complete". Selecting Tools/Language - gets a check mark for English (USA) and no others.

Looking in: "Tools->Options ..., Language Settings->Writing Aids" Items with checks are the following:

Lightproof grammar checker English.

Standard all English. en US english USA. Technical all. IgnoreAllList all.

Check spelling as you type. Check uppercase words. Check special regions. Minimum number . . . . . 5 Characters before . . . . 2 Characters after. . . . . . 2 Hyphenate special regions.

edit flag offensive delete link more

Comments

Regarding: "in tools - Options - Language settings - Languages - Default Languages for Documents." The defaults are set for English USA.

jharpj gravatar imagejharpj ( 2016-11-22 16:42:56 +0200 )edit

This isn't an answer, please repost as a question. This board is hard enough to handle, you can't have more than one specific question in one thread. Hunspell spell checker should be on.

floris v gravatar imagefloris v ( 2016-11-22 16:58:08 +0200 )edit

You say "Repost as a question" then say "You can't have more than one specific question in one thread." That only serves to further confuse me. My second posting was not a question but was an attempt to supply more information as I was told. (???) Doesn't the information I posted answer your questions? Also how do I turn on "Hunspell spell checker"?

jharpj gravatar imagejharpj ( 2016-11-23 17:41:19 +0200 )edit

Sorry, I must have been very confused when I posted that comment.

floris v gravatar imagefloris v ( 2016-11-23 18:38:58 +0200 )edit

This problem was solved - is there something I'm supposed to do to close it?

jharpj gravatar imagejharpj ( 2016-12-14 01:45:52 +0200 )edit
1

If my answer helped you, please vote it with ✔ (here on the left). That will help other people with the same question.Tick the

floris v gravatar imagefloris v ( 2016-12-14 09:14:30 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-11-22 07:16:10 +0200

Seen: 34,627 times

Last updated: Jul 10 '20