Spell check doesn't work

Spell check doesn’t work.
I get a check mark for English USA but not Paragraph or for all text. The spell checker still doesn’t work although when I start a sentence with a lower case letter it corrects it.

Have you checked in ToolsOptions ..., Language SettingsWriting Aids that the modules, dictionaries and desired options are enabled?

Please provide more information for questions like this. Like: has it worked before but is this a sudden change in behavior of Libre, or have you just installed it and doesn’t it work out of the box, like that. If you are completely new to LibreOffice, you don’t need to reset the user profile as in my answer.

Mine did not work. I downloaded the extension for English (USA) which was part of the latest bundle and installed the bundle and I think I added English (USA) to my dictionaries. Still it did not work. I searched here and found all the options suggested in the other answers were checked already including hunspell. So then I changed from the default English USA to this one I had downloaded in the Options > Language Settings > Languages > Default Languages for Documents. Then after Libre Office restarted, it worked.

I had to make sure LibreOffice knew my text was English. Select all text, right click > Styles > Edit Style. Click the Font tab. Don’t change the font, just change the language to “English (USA)”

You can make this automatic for new documents in the Options menu, as Stephen Mikesell notes above.

1 Like

This Worked! My LibreOffice had been working great for years, then suddenly the spell checker just gave me blank forms. I did the “Writing Aids” but it didn’t help me. The “Default Languages” was set to German. I don’t know how that happened, but I speak English (American Southern Style!). That change fixed it. THANK YOU!

This worked perfectly. Except its highlight the text->right click->paragraph->edit styles…then the same. Thanks so much!

Reset your user profile. See Frequently asked questions - General - The Document Foundation Wiki - important: rename the folder, don’t delete it. Resetting the user profile solves many problems.

You have to assign a language to your text, or the spell checker won’t work. You can do that in tools - Options - Language settings - Languages - Default Languages for Documents. But you cal also modify the Default paragraph style, select the Font tab and select a language there.

Please note that the spell checker doesn’t automatically correct any errors, it just highlights them. Lowercase changing to uppercase is Autocorrect’s work. Take a look at Tools - Autocorrect - Autocorrect options to see what it will do for you (and disable anything that you don’t like).

EDIT: Make sure that hunspell is also ticked, that’s the actual spell checking module. There’s a bug in Apache OpenOffice, and maybe in Libre as well, that messes up spell checking for files created in Windows Explorer (the file manager, not the Internet browser). Can you get the spell checking to work in files created within Writer? If you can, upload a sample file for testing purposes.

image description

You can also try Tutorial Spell check and Language configuration - and check in at that forum to get more help. When you register, you need to provide a (fake) version of OpenOffice that you use, a trick to defeat spam bots.

1 Like

Spelling doesn’t correct files created by LO or MSO.
I can’t find “Hunspell” or instructions regarding it - so can’t see if it’s ticked. Maybe somebody will tell me?

Tools>Language Settings>Writing Aids should show 3 Boxes. The top one “Available language modules:” should show as in the picture from @floris_v. This shows “Hunspell”.

When I go to >Options - Language Settings - Writing Aids< the only module shown is "Lightproof grammar checker (English)

Hunspell is not there under Writing aids or anywhere elsse.Lacking any further instructions on how to install Hunspell into the list I guess that I am to select Edit - get more dictionaries online but find I am unable to find Hunspell. Please tell how to find and install Hunspell . . . .Thanks.

You have to run the install program for LibreOffice again. This is a serious failure. Did you download the program from the official site?

I deleted the previous version of LO and installed a new one - nothing has changed. Both downloads were from www.Libreoffice.org/download

Still no hunspell module? It seems to me that direct access to your computer is necessary to solve this. That means: ask a friend who is more comfortable with computers than you are to sort this out. Questions can be asked at http://forum.openoffice.org/en/forum/ (easier comnnumication than here, for registration you have to add a (phoney) version of OpenOffice).

Problem solved.

Early on in this session I was advised that changing the user profile was not necessary. Well guess what? It was - and it seems to have fixed my spellcheck problem.
Thank you very much for your time and interest in solving this.

I supposed that if this was the first time ever that you installed LibreOffice, the user profile couldn’t be corrupted yet. But apparently it can. How long have you had LibreOffice?

Since 11/5/2016
And now with the spell check working I am a happy camper.
.

Okay, that’s long enough for it to get corrupted. Pity I thought you had just downloaded and installed it. Glad it’s solved. :slight_smile:

“Make sure that hunspell is also ticked” - yes, that should be the first proffered solution.

Also, it is my experience that sometimes hitting the Apply button will actually toggle the Check spelling as you type" option, meaning if you have that option highlighted and deselect it with your mouse and hit Apply, then it will placed the check mark in it to activate it, but if you hit Apply again it will deselect it. But if your use your mouse to activate it and hit OK then it will work.

That doesn’t happen for me. Maybe there’s something wrong in your version of LibO. Regardless, that kind of thing deserves its own topic. This topic was marked as solved, you shouldn’t start a new discussion in it. We want to keep this board tidy.