Ask Your Question
0

to reset password to default type

asked 2016-11-24 18:06:13 +0200

koolninja gravatar image

i used ALTER USER "SA" SET PASSWORD "something" in split database

after this popup asking password this ok but now want simple direct opening base file without password login popup. i used ALTER USER "SA" SET PASSWORD "" i set password blank but don't get rid of popup.

any advice to get out of username and password popup screen

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2016-11-24 20:40:04 +0200

Ratslinger gravatar image

This appears to be a bug. From main .odb screen go to menu Edit->Database->Properties... you will see Password required is selected. You can remove the selection and save but it never gets cleared no matter what. That is the bug.

You can fix with an edit to a file in the .odb. Best to have a copy of the .odb in case you mess something up in the process. It's simple but best be safe. Open the .odb with an archive program. Then open the content.xml file with a text editor. In the file you will find the following item:

is-password-required="true"

Change to:

is-password-required="false"

Save the file and the content of the .odb and then you should not have the popup anymore.

edit flag offensive delete link more

Comments

this process is works... thanks

koolninja gravatar imagekoolninja ( 2016-11-27 10:56:10 +0200 )edit

I first asked what kind of archive program to use, as Linux Mint's Archive Manager, pzip or gzip don't like the .odb file extension. Then I found an article on fileinfo.com saying I could simply rename the .odb to .zip and open it. That worked, but trying to re-compress the files into a .zip and renaming to .odb gave me a "Corrupt file" error when loading with LO. The original poster seemed to like your solution, but ... I guess I'm missing something and am now editing my original question. Can you give specifics?

rob1grie gravatar imagerob1grie ( 2020-06-19 12:16:49 +0200 )edit
0

answered 2020-06-19 12:41:59 +0200

rob1grie gravatar image

I was a little slower figuring this out, but there's another post here that made it a little clearer.

  1. Rename the .odb extension to .zip
  2. Double click the .zip file to open with the OS archive viewer (I'm using Linux Mint)
  3. Double click content.xml to open with the default text editor
  4. Change is-password-required="true" to is-password-required="false"
  5. Save and close the editor.
  6. Back at the archive viewer, mine prompted whether to update the file in the archive. I confirmed with OK, closed the archive viewer, renamed the .zip to .odb and problem resolved.

Thanks @Ratslinger for pointing me in the right direction!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-11-24 18:06:13 +0200

Seen: 291 times

Last updated: Jun 19