Ask Your Question
2

Writer - Problems with bibliography formatting

asked 2016-12-10 12:54:41 +0200

Songs_n_Socks gravatar image

updated 2016-12-10 16:06:14 +0200

I don't know how to describe this - but I have a new computer and the most recent version of LibreOffice and my .doc documents, created with the LibreOffice on my old computer look super weird now.

Like, if I copy and paste the stuff into this window it comes out looking right, but in my libreoffice it looks like gibberish.

I would attach a document or picture but I don't have enough points?

Can I downgrade to a different libre office?

Document example C:\fakepath\bibliography (1).doc

This is how it looks for me image description

edit retag flag offensive close merge delete

Comments

I mean, it's not even true for all my documents but particularly my bibliographies are full of gibberish.

Songs_n_Socks gravatar imageSongs_n_Socks ( 2016-12-10 13:14:41 +0200 )edit

I'm using LibreOffice 5.2 now.

Songs_n_Socks gravatar imageSongs_n_Socks ( 2016-12-10 13:20:41 +0200 )edit

Hi @Songs_n_Socks I have increased your karma, I think you should be able to attach a file now

pierre-yves samyn gravatar imagepierre-yves samyn ( 2016-12-10 14:51:46 +0200 )edit

Hi @pierre-yves samyn, thank you. Attached document. it looks fine! Whyyy does it not look fine when opened with my libre office? It drives me nuts

Songs_n_Socks gravatar imageSongs_n_Socks ( 2016-12-10 16:05:22 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2016-12-10 17:52:29 +0200

Songs_n_Socks gravatar image

image description

This is how it looks @floris v

edit flag offensive delete link more
0

answered 2016-12-10 16:51:18 +0200

floris v gravatar image

updated 2016-12-10 18:29:54 +0200

It looks fine in my copy of LibreOffice. The first solution seems to be: Reset your user profile. Shut down LibreOffice, including the Quickstarter if you still use that. Then rename the user profile folder - the folder called "user" - important: rename it, don't just delete it if you have many customizations and macros.

You wrongly use tabs to indent the second, and sometimes the third line of an item. Instead use a hanging indent, see attached edited file. C:\fakepath\14813821437851995a.docimage description Extraordinary claims require extraordinary proofs. ;) Here's the odt version: C:\fakepath\14813821437851995a.odt

edit flag offensive delete link more

Comments

Uninstall or just close?

Songs_n_Socks gravatar imageSongs_n_Socks ( 2016-12-10 17:20:52 +0200 )edit

Just close. Uninstalling doesn't help - if it did, you'd have a problem when you install a new version of Libre. Uninstalling leaves your customizations (and that's what's in the user profile) alone.

floris v gravatar imagefloris v ( 2016-12-10 17:32:41 +0200 )edit

So @floris v I did that and the document still looks as in the screenshot above. I checked in the folder and libre office just created a new folder called "user" after I renamed the old one.

Songs_n_Socks gravatar imageSongs_n_Socks ( 2016-12-10 17:34:54 +0200 )edit

Okay, then we need to look for another cause, but keep this one in mind, it solves a large number of problems.

floris v gravatar imagefloris v ( 2016-12-10 17:36:55 +0200 )edit

I'm on 5.2.3.3, if you are on that as well, that's not the problem. You do have the required font, and how does the file look that I attached?

floris v gravatar imagefloris v ( 2016-12-10 17:39:42 +0200 )edit

The same (see my answer)

Songs_n_Socks gravatar imageSongs_n_Socks ( 2016-12-10 17:57:59 +0200 )edit

UGH WHY DOES IT LOOK LIKE THAT FOR ME.

Songs_n_Socks gravatar imageSongs_n_Socks ( 2016-12-10 18:03:15 +0200 )edit

Maybe you should do the re-install. You can also sign up at http://forum.openoffice.org/en/forum/ and ask your question there. people there are helpful. Just enter a fake AOO version in your signature to get past the registration procedure (a trick to deflect spam bots).

floris v gravatar imagefloris v ( 2016-12-10 19:54:49 +0200 )edit
0

answered 2016-12-16 19:30:11 +0200

Hynerian gravatar image

Is this enabled: Tools - Options - LibreOffice - View - Use OpenGL for all rendering? If yes, try to disable it and restart LibO.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-12-10 12:54:41 +0200

Seen: 200 times

Last updated: Dec 16 '16