Ask Your Question
0

Double line cell borders in calc drawn incorrectly [closed]

asked 2012-12-05 16:20:25 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I just installed Version 3.6.3.2 (Build ID: 58f22d5) on my Windows XP Pro SP3 system and have yet to find a way to get a double-line border to display correctly in calc. In past versions, I think the "Width" attribute was intended to specify the thickness of the line itself-- the gap between the lines was perhaps "scaled" to make sense. Or perhaps the line width was what was being "scaled" based on the overall border "width". Which ever is the case, something appears to be broken now :(

Here is a png of a test spreadsheet I just created which shows cells with double-line borders of various "Width" specifications:

http://jjmmjmmm.com/LOBugs/double-line-border-bug-demo.png

http://jjmmjmmm.com/LOBugs/double-line-border-bug-demo.ods

BTW- Here is a view with Anti-Aliasing turned off (thanks mariosv) and also a view using IBM Lotus Symphony.

LibreOffice scalc Version 3.6.3.2 (Build ID: 58f22d5) Anti-Aliasing OFF

http://jjmmjmmm.com/LOBugs/double-line-border-bug-demo-aa-off.png

With Anti-Aliasing OFF, some of the double-line borders do appear reasonable. But for the most part, the results don't seem all that predictable based on the "Width" specified :(

Lotus Symphony 3 ; Release 3.0.1 FP1 ; Revision 20120424.2015

http://jjmmjmmm.com/LOBugs/double-line-border-bug-demo-ils.png

FWIW- IBM Lotus Symphony also has an Anti-Aliasing configuration option, but either OFF or ON, the borders appear the same.

Regarding printing (export to pdf), for LibreOffice, the Anti-Aliasing configuration option had no effect:

http://jjmmjmmm.com/LOBugs/double-line-border-bug-demo-aa-on.pdf

http://jjmmjmmm.com/LOBugs/double-line-border-bug-demo-aa-off.pdf

And to add further fascination to this saga, although I found IBM Lotus Symphony's visual display of double-line borders nearly perfect, when exported to PDF, IBM Lotus Symphony's printed versions look a lot like the broken LibreOffice screen representation:

http://jjmmjmmm.com/LOBugs/double-line-border-bug-demo-ils-aa-on.pdf

http://jjmmjmmm.com/LOBugs/double-line-border-bug-demo-ils-aa-off.pdf

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-19 12:46:52.823626

Comments

manj_k gravatar imagemanj_k ( 2013-06-17 00:02:55 +0200 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2012-12-10 17:43:24 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

After reading horst's bug link, I have to agree that the bug being discussed in

https://bugs.freedesktop.org/show_bug.cgi?id=53287

is what I am experiencing. However, this is not a bug that has been around for years :(... I have been perfectly satisfied with all the versions of LibreOffice I have used until just now.

edit flag offensive delete link more

Comments

BTW- Since I was interested in a double-line border at the bottom of a cell to visually divide a column of numbers from their "total", I merely created a very thin row and specified a thin, single-line top and bottom cell border. Both on the screen and in pdf form, the representation was correct.

jeb6kids gravatar imagejeb6kids ( 2012-12-10 17:49:50 +0200 )edit

fdo#53287 has been marked as a duplicate of Bug 56960 - FILEOPEN particular .xlsx shows cell border lines with wrong FORMATTING (too thick)
Status: RESOLVED FIXED (LibreOffice 4.1.0)

manj_k gravatar imagemanj_k ( 2014-07-30 22:17:57 +0200 )edit
0

answered 2012-12-05 17:19:23 +0200

famo gravatar image

Did you tried printing the file or zooming in?

If I zoom in on your file everything looks fine to me, see also attached screenshot: image description Clipboard01.png

If that is not your problem, please explain further.

edit flag offensive delete link more
0

answered 2012-12-05 22:48:01 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Sometimes, changing the option in Menu/Options/Tools/LibreOffice/View - Use Anti-Aliasing, help.

edit flag offensive delete link more
0

answered 2012-12-05 21:14:24 +0200

horst gravatar image

This is a problem for many years see here.

Goto Tools -> Options: in Libreoffice - view uncheck "use Anti-Aliasing". It worked fairly good for me.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-12-05 16:20:25 +0200

Seen: 1,655 times

Last updated: Dec 10 '12