Printing page orientation wrong in OS X

asked 2017-02-21 17:06:41 +0200

Snaify gravatar image

I have checked every single setting I could find in any menu for Libre Office Vanilla, including print options and print preview and page orientation and view settings, etc. Even when setting the print options to print portrait, it does not matter. Nothing helps. Print preview shows normal portrait, but print jobs from LibreOffice Vanilla on my late 2015 iMac (running OS X Sierra 10.12.3) insist on printing landscape. The only way to get a job to print correctly has been to convert to PDF, open the PDF in Adobe, then print from there. This is not a long-term solution, as PDF's cannot be edited, so any changes have to made in LO and then re-converted to PDF before opening in Adobe and printing again! This adds more steps to my jobs, and doesn't not always maintain my formatting. This was never an issue on my 2012 MacBook Pro, but is now the norm on my late 2015 iMac. I know I am not the only user reporting this issue. I would be immensely grateful if my query were to propel assistance with this! I think it may be something other than a user settings problem. Thank you!

edit retag flag offensive close merge delete

Comments

I also have this same problem and only since I upgraded to version 5.4.2. The previous version 5.0.x did not have this issue. I run Sierra 10.12.4 on a late 2010 macbook pro.

tmays661 gravatar imagetmays661 ( 2017-08-14 01:55:11 +0200 )edit

Definitely something wrong with LibreOffice and printing. I installed the fresh version, still the same. Tried the version from the Apple app store. I did remove all the files in application support folder, and the application(s) themselves. Removed all the versions and the app support and installed the stable 5.3 version from the website. Still the same effect. New documents are also affected.

Murray Mitchell gravatar imageMurray Mitchell ( 2017-09-01 16:05:25 +0200 )edit

Me too! Maddening! Base doesn't work at all either. I have a 100 page database that Is now useless. I've submitted bug reports but they don't seem to agree with bugzilla.

Ambimom gravatar imageAmbimom ( 2017-09-08 20:40:34 +0200 )edit

Using Sierra 10.12.6 with stable version 5.3.5.2. We have multiple clients with the same issue after upgrade.

tmigeek gravatar imagetmigeek ( 2017-09-21 21:01:21 +0200 )edit

Have you solve this issue ? I am having the same problem. Last time with one iMac now with several after LO upgrade. Last time I solve this resetting printing settings. But now it doesn´t seem to work.

gsolera gravatar imagegsolera ( 2017-09-25 17:48:02 +0200 )edit

I'm another one—using Mac Sierra. Happened only after upgrade to 5.3.1. and Yes, the Page Format is set correctly. Happens ONLY in Letter size, Does NOT happen in A4 nor Legal sizes, which is a workaround but not a solution. Is LO working non this?

rjohn-mus gravatar imagerjohn-mus ( 2017-10-01 19:26:09 +0200 )edit

I have this same problem. I did not have this problem until I upgraded to Sierra 10.12.6 and LibreOffice 5.3.6.1. Since I did both upgrades at about the same time I'm not sure which one to blame. My work around has been to save my documents with the doc extension and then open them with OpenOffice and print from there.

donmck gravatar imagedonmck ( 2017-10-03 01:37:28 +0200 )edit

The problem seems to occur only when the paper size is set to "letter" which is 8.5 x 11.0. If you manually set the paper size to 8.5 x 10.98 it will work ok.

donmck gravatar imagedonmck ( 2017-10-03 04:29:59 +0200 )edit

Same problem for me with 5.4.1 on Mavericks. I tried downgrading to "stable" version (5.3.6), trashing prefs, resetting printing system all to no avail. As a workaround I downloaded the last version prior to 5.3 from here and it works correctly:

https://downloadarchive.documentfound...

Can someone from LO chime in here?

CheddarNeck gravatar imageCheddarNeck ( 2017-10-03 15:13:11 +0200 )edit

I'm experiencing this same problem.

michbrinson gravatar imagemichbrinson ( 2017-12-05 17:44:48 +0200 )edit