We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

How do you prevent -- from being auto-corrected to an em-dash [closed]

asked 2017-03-09 14:50:04 +0200

uihdff gravatar image

updated 2020-09-27 13:37:06 +0200

Alex Kemp gravatar image

Using version 5.3.0.3 (x64)

How do you prevent Writer from autocorrecting two dashes to an em dash ?

I'm trying to write:

iptables -I INPUT -i vlan2 -m state --state NEW -j DROP

But it keeps getting autocorrected to:

  iptables -I INPUT    -i vlan2  -m state  <em dash>state NEW  -j DROP
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-09-27 13:37:52.541850

2 Answers

Sort by » oldest newest most voted
1

answered 2017-03-09 15:27:30 +0200

karolus gravatar image

create a Paragraph-style with Locale `None' inside Font-settings, and use that Parastyle for this Input.

→→Styles→Paragraphstyles →→New…

edit flag offensive delete link more
0

answered 2017-03-09 21:14:17 +0200

JohnHa gravatar image

updated 2017-03-09 21:15:43 +0200

Tools > AutoCorrect Options > Replace ... - remove it if there.

Tools > AutoCorrect Options > Options ... - untick Replace dashes

Click the Help button on the pop-up for more information.

edit flag offensive delete link more

Comments

Yes, but maybe you need this autocorrection in other context…

karolus gravatar imagekarolus ( 2017-03-09 22:34:21 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2017-03-09 14:50:04 +0200

Seen: 1,184 times

Last updated: Mar 09 '17