Ask Your Question
1

El ejemplo de Access2base -> TT NortWind.odb no funciona bién The example of Access2base -> TT NorthWind.obd does not work well

asked 2017-03-13 20:37:34 +0100

josefito gravatar image

updated 2017-03-14 00:05:07 +0100

peterwt gravatar image

He observado que el modelo que tiene la página web access2Base que es ( TT NortWind.odb ) no funciona en el Libreoffice 5.3.1, igual me pasaba a mi con mi programa. Esto me hace pensar que existe un problema de entenimiento en Libreoffice 5.3.1 que no permite llamar normalmente a una librería como la de access2base como venía haciéndolo hasta ahora.

Un saludo

TRANSLATED @peterwt

I have noticed that the model that has the web page access2Base that is (TT NortWind.odb) does not work in Libreoffice 5.3.1, just like me was happening to me with my program. This makes me think that there is a problem of understanding in Libreoffice 5.3.1 that does not allow calling normally to a library like access2base as it had been doing so far.

a greeting

edit retag flag offensive close merge delete

Comments

1

Use English please. There's also https://ask.libreoffice.org/es/questi... that may be suitable and more convenient for you.

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-13 20:59:43 +0100 )edit

LO v5.3.0.3 is the latest general release beside daily versions. What version are you talking about? I have little problem with this .odb in v5.3.0.3 and earlier versions. What specific problem are you talking about? What OS do you have?

Ratslinger gravatar imageRatslinger ( 2017-03-14 04:35:52 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-03-15 22:58:08 +0100

josefito gravatar image

updated 2017-03-15 23:04:14 +0100

WINDOWS 7 and WINDOWS XP

Libreoffice 5.3.1 and Libreoffice 5.2.6

calling library access2base

thank you

call_access2base error.odt

edit flag offensive delete link more
0

answered 2017-03-15 23:08:50 +0100

Ratslinger gravatar image

updated 2017-03-15 23:49:35 +0100

Still not sure exactly what your problem is. For a working sample .odb see my answer in this post - click here. This should give you a working sample to start with including loading the library.

Edit: Sorry, didn't see the attached sample.

Your problem is not with the library. It seems to be from the MAXIMIZE statement. The syntax on the Access2Base site is :

Dim ofForm As Object
Set ofForm = Forms("myForm")
ofForm.SetFocus
Maximize()          '   ... or Minimize() ...

Of course you have to open the form first. This routine works for me (just tested):

Sub MyOpenForm
    Const acFormReadOnly = 2
    OpenForm "Form2", , , , acFormReadOnly
    Dim ofForm As Object
    Set ofForm = Forms("Form2")
    ofForm.SetFocus
    Maximize()          '   ... or Minimize() ...
End Sub
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-03-13 20:37:34 +0100

Seen: 150 times

Last updated: Mar 15 '17