Ask Your Question
0

How do I change default paper settings from "letter" to "A4"?

asked 2017-03-25 23:21:14 +0200

IanIndia gravatar image

LIbreOffice came pre-installed on my Kingdel Ubuntu pc. I cannot find any settings to change the default paper size to the standard UK size, which is A4. I need all settings to be be set to UK norms as a default. Please advise

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-03-26 00:30:05 +0200

JohnHa gravatar image

Create a new default template with an A4 page and save it.

From the AOO manual:

*Setting a default template

If you create a document by choosing File > New > Text Document from the main menu, Writer creates the document from the Default template for text documents. You can, however, set a custom template to be the default. You can reset the default later if you choose.

Setting a custom template as the default

You can set any template to be the default, as long as it is in one of the folders displayed in the Template Management dialog box. If necessary, you can add the template to a folder as described in “Importing a template” on page 300.

To set a custom template as the default:

1) From the main menu, choose File > Templates > Organize. The Template Management dialog box (Figure 294) opens. 2) In the box on the left, select the folder that contains the template that you want to set as the default, then select the template. 3) Click the Commands button and choose Set as Default Template from the drop-down menu.

The next time that you create a document by choosing File > New > Text Document, the document will be created from this template.

Although many important settings can be changed in the Options dialog (see Chapter 2), for example default fonts and page size, more advanced settings (such as page margins) can only be changed by replacing the default template with a new one.

Resetting Writer’s Default template as the default

To re-enable Writer’s Default template as the default:

1) In the Template Management dialog box (Figure 294), select any folder in the box on the left. 2) Click the Commands button and choose Reset Default Template > Text Document from the drop-down menu.

The next time that you create a document by choosing File > New > Text Document, the document will be created from Writer’s Default template.*

edit flag offensive delete link more

Comments

@JohnHa: does not LO take its default paper size from the printer definition? In which case, changing the settings in the printer (OS-wide) will propagate to all apllications.

ajlittoz gravatar imageajlittoz ( 2017-03-26 08:12:54 +0200 )edit
1

@ajlittoz: no; rather, it uses locale to decide on default paper size.

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-26 10:48:22 +0200 )edit

@Mike Kaganski: Thanls for the answer; locale is also an OS-wide parameter.

ajlittoz gravatar imageajlittoz ( 2017-03-26 15:11:05 +0200 )edit

Perhaps LO changes its interface too often? This is less than a year after this post was written. There's no link to the "AOO Manual" (what's that?), so I can't check to see if it has been updated.

  • There are no folders listed in the template management dialog box.
  • There's no "Organize" under File > Templates. There is a "Manage Templates" option, but there aren't any templates listed. I certainly saved my template in the wrong place, but I don't have any way to know the right place.
VinceAggrippino gravatar imageVinceAggrippino ( 2018-01-13 08:52:29 +0200 )edit

@VinceAggrippino: Well, perhaps you were misinformed, and so made to believe into what is not correct.

The "AOO manual" is the manual for Apache OpenOffice, and it may well be out-of-date with LibreOffice interface for long ago. Still, the answer isn't entirely useless, because even if some interface details might be wrong, the principle is clear, and is useful for those who are more accustomed to our interface, and may figure the correct UI from the loose description.

Mike Kaganski gravatar imageMike Kaganski ( 2018-01-13 11:37:50 +0200 )edit
0

answered 2017-03-26 10:51:48 +0200

Please check that you locale (Tools-Options-Language Settings-Languages) is set properly. E.g., for English (USA), the default page size if Letter, while for English (UK) it's A4.

edit flag offensive delete link more

Comments

It's worth doing this as an initial diagnostic step, but in my case, my locale settings are correct as checked from the command line and within Gnome 3. Other GUI applications under my desktop environment work correctly - the printer default is set correctly, and I can print, by default, in A4, from every application other than LibreOffice.

Under LibreOffice, the print dialogue to change the paper format is greyed out. I think this is a bug in LibreOffice.

salafrance gravatar imagesalafrance ( 2017-10-12 12:31:29 +0200 )edit

https://bugs.documentfoundation.org/s...

Another option is that you could set a default template with defined page size.

Please notice that system printer settings shouldn't mean anything to applications like Writer.

Mike Kaganski gravatar imageMike Kaganski ( 2017-10-12 16:23:21 +0200 )edit

Note that the whole concept of default page sizes, just as default date settings, is broken in LibreOffice, just as it is in Linux, Android, and a host of other OS's, applications, and printer drivers. It is always assumed that paper sizes and date settings a user needs strictly follow from their choice of either location or language. This is of course not always the case, and especially in case of "US English" this is /very often/ not the case, as many people [FUCK INSANE CHARACTER LIMITATION]

VlijmenFileer gravatar imageVlijmenFileer ( 2018-07-22 14:52:40 +0200 )edit

Note that the whole concept of expectation that any default page size not explicitly set by user could fit everyone, is broken in those who think that. And LibreOffice allows user to set the defaults explicitly - by using templates, or adjusting the locale settings in the application independently of system settings if user wants. It's funny how some people make broad statements about something being broken.

Mike Kaganski gravatar imageMike Kaganski ( 2018-07-22 15:37:16 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-03-25 23:21:14 +0200

Seen: 12,990 times

Last updated: Mar 26 '17