How to change default page size to Letter rather than A4?

I wanted to ask & answer this here for the benefit of others. The reverse question was answered at How do I change default paper settings from "letter" to "A4"? - #17 by JohnCyrmu, and the answer for this is very similar.

If your paper size is A4 and your locale setting in LibreOffice is “Default - English (USA)” then choosing “English USA” (no “Default -”) will fix it, which is to say that it will make the paper size default to Letter, not A4.

To make the change, go to Tools → Options… → Language Settings → Languages, and then choose the value from the Formats → “Locale setting” dropdown.

You didn’t say what operating system you use, but if Linux:

The proper way to set the paper size on Linux systems is to tell your system or user environment, not have workarounds in LibreOffice. The paper size is used that the command paperconf gives in the environment LibreOffice was started in.
man paperconf
man papersize
Summary:
File /etc/papersize Contains the name of the system-wide default paper size to be used if the PAPERSIZE and PAPERCONF variables are not set.
Environment variable PAPERCONF Full path to a file containing the paper size to use.
Environment variable PAPERSIZE Paper size to use regardless of what the papersize file contains.
Environment variable LC_PAPER Locale’s paper size to use if none of the above, not even /etc/papersize, is set.