Ask Your Question
1

AutoFilter no longer working with dates in calc

asked 2017-04-18 13:48:50 +0200

nikim gravatar image

updated 2017-04-18 17:59:58 +0200

Lupp gravatar image

AutoFilter not working with dates. Tested on versions: 5.2.6.2 and 5.3.2, x86 x64

Example: The initial data. https://yadi.sk/i/Xp_-8mjZ3H6Zm6 With this filter, the data is displayed. https://yadi.sk/i/fbsZWMLP3H6Zs8 If you remove at least one tick in the filter, no data is displayed. https://yadi.sk/i/fukyIQoW3H6ZxP

edit retag flag offensive close merge delete

Comments

Why didn't you upload a spreadsheet file (.ods). You don't ask about anything concerning the view. You question is about the working of a tool.. There's a lot we can miss looking at images.in this case. Are you sure, e.g. your dates are actually dates in the spreadsheet sense: Numeric data, just displayed in a specific format. The picture doesn't give a hint with this respect.
However, I would assume a bug here.

Lupp gravatar imageLupp ( 2017-04-18 14:50:27 +0200 )edit

I can confirm the described behavior.

The automatic filter does not work with Dates in LibreOffice Calc version 5.2.6.2 x64

Any filter different from All gets no rows as result.

You can test yourself by creating a new Spreadsheet Calc and entering three data:

Document Date 01/26/2017 02/13/2017

Then activate AutoFilter.

Try using the filter selector.

The standard filter works but unfortunately does not have the same power of AutoFilter.

Gianni1962PcIT gravatar imageGianni1962PcIT ( 2017-04-18 16:26:23 +0200 )edit

Yes. I also confirmed it for LibO Calc V 5.3.2 meanwhile.
I could not find a bug report yet concerning this behaviour. The bug tdf#107082 is significantly different. If you or you file a report about this specific bug, please also link it into this thread.

Lupp gravatar imageLupp ( 2017-04-18 16:42:02 +0200 )edit

Test data. Work: 5.1.6.2. Not Work >=5.2.6.2 https://yadi.sk/i/FoPc4_ne3H6z8t

nikim gravatar imagenikim ( 2017-04-18 16:51:15 +0200 )edit

Thanks @nikim. You should now be able to attach files directly to your posts in this forum.

Lupp gravatar imageLupp ( 2017-04-18 17:35:02 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2017-04-18 17:28:05 +0200

Lupp gravatar image

updated 2017-04-18 20:03:12 +0200

This is clearly a bug introduced with some version of the 5.2 series.
As I myself only tested with V5.3.2 I reported it for this version as bug tdf#107245. Anybody having tested with an earlier version may change the respective setting. This is my demonstration (.ods).

By the way:
The bug will not survive if the dates are formatted in "human readable ISO 8601 format" YYYY-MM-DD, which is anyway the date format that always should be used in spreadsheets , and also in texts.

Edit1:
There was an older bug report concerning the issue: tdf#106214
It is marked RESOLVED FIXED. The fix will be available in V5.3.3.

edit flag offensive delete link more

Comments

Thank you.

nikim gravatar imagenikim ( 2017-04-19 06:56:19 +0200 )edit
0

answered 2017-08-29 19:13:02 +0200

KMan94 gravatar image

updated 2017-08-29 22:56:18 +0200

I've been following this problem for sometime and it still doesn't work. I'm on 5.3.4.2 x64 and still broke. Is there an update or something I can do to assist the correction?

edit flag offensive delete link more

Comments

Please make accessible an example showing the issue for you.
Based on my examples I cannot confirm your claim. V 5.3.4.2 works well for me. I would not expect that this can depends on the nuild (which is in my case Win 32 bit for PortableApps).

Lupp gravatar imageLupp ( 2017-08-29 20:43:36 +0200 )edit

Wolfgang,

Thank you for your quick reply. First, I am wrong. I have found that it works. I discovered this as I was getting my spreadsheet ready to make available to you. I realized it was saved as a .xls file. I'd done that sometime ago to get around the filter problem but had forgotten to change it back.

I re-saved it as a .ods file and retested the filters and they worked flawlessly.

My apologies. Thank you again.

Kevin

KMan94 gravatar imageKMan94 ( 2017-08-29 23:02:51 +0200 )edit
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2017-04-18 13:48:50 +0200

Seen: 1,329 times

Last updated: Aug 29 '17