AutoFilter no longer working with dates in calc

AutoFilter not working with dates.
Tested on versions: and 5.3.2, x86 x64

The initial data.
With this filter, the data is displayed.
If you remove at least one tick in the filter, no data is displayed.

Why didn’t you upload a spreadsheet file (.ods). You don’t ask about anything concerning the view. You question is about the working of a tool.. There’s a lot we can miss looking at this case. Are you sure, e.g. your dates are actually dates in the spreadsheet sense: Numeric data, just displayed in a specific format. The picture doesn’t give a hint with this respect.
However, I would assume a bug here.

I can confirm the described behavior.

The automatic filter does not work with Dates in LibreOffice Calc version x64

Any filter different from All gets no rows as result.

You can test yourself by creating a new Spreadsheet Calc and entering three data:

Document Date 01/26/2017 02/13/2017

Then activate AutoFilter.

Try using the filter selector.

The standard filter works but unfortunately does not have the same power of AutoFilter.

Yes. I also confirmed it for LibO Calc V 5.3.2 meanwhile.
I could not find a bug report yet concerning this behaviour. The bug tdf#107082 is significantly different. If you or you file a report about this specific bug, please also link it into this thread.

Test data. Work: Not Work >=

Thanks @nikim. You should now be able to attach files directly to your posts in this forum.

This is clearly a bug introduced with some version of the 5.2 series.
As I myself only tested with V5.3.2 I reported it for this version as bug tdf#107245. Anybody having tested with an earlier version may change the respective setting. This is my demonstration (.ods).

By the way:
The bug will not survive if the dates are formatted in “human readable ISO 8601 format” YYYY-MM-DD, which is anyway the date format that always should be used in spreadsheets , and also in texts.

There was an older bug report concerning the issue: tdf#106214
It is marked RESOLVED FIXED. The fix will be available in V5.3.3.

Thank you.

I’ve been following this problem for sometime and it still doesn’t work. I’m on x64 and still broke. Is there an update or something I can do to assist the correction?

Please make accessible an example showing the issue for you.
Based on my examples I cannot confirm your claim. V works well for me. I would not expect that this can depends on the nuild (which is in my case Win 32 bit for PortableApps).


Thank you for your quick reply. First, I am wrong. I have found that it works. I discovered this as I was getting my spreadsheet ready to make available to you. I realized it was saved as a .xls file. I’d done that sometime ago to get around the filter problem but had forgotten to change it back.

I re-saved it as a .ods file and retested the filters and they worked flawlessly.

My apologies. Thank you again.