Ask Your Question
0

Where did my scroll-bars go?

asked 2017-05-19 08:43:25 +0100

PaulG gravatar image

As a follow-up to https://ask.libreoffice.org/en/questi...

I upgraded to version 5.3.3.2, and I now have no scroll-bars at all in my documents. They're not simply invisible (or hard to see due to limited contrast with surrounding display entities), they don't exist, and document content spreads to the full extent of the enclosing window. The Page-Up, Page-Down, and Home buttons still work, so it's possible to navigate through a document, but scroll-bars are so much more intuitive (at least to me)!

I'm fairly certain that this is an issue in one of the many libraries on which libreoffice depends, but I don't know which one is the culprit, and I haven't a clue on how to get back to either the original behavior (traditional Scroll-Bar with thumb, and Page-up/Down depending on where you click) or the previous behavior (move to position in document corresponding to relative position of click within scroll bar region).

edit retag flag offensive close merge delete

Comments

a friend of mine pointed out

tdf#106645 gtk3 scrollbar is too wide [CaoláMcNamara]

I wonder if this is related? My scroll bars were never too wide - indeed, wider would have been nice!

PaulG gravatar imagePaulG ( 2017-05-19 08:53:56 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-05-19 10:28:31 +0100

librebel gravatar image

Hello @PaulG, try check the menu items "View : Scrollbars : Horizontal Scrollbar" and "View : Scrollbars : Vertical Scrollbar"

edit flag offensive delete link more

Comments

My View menu does not have a Scrollbars entry.

PaulG gravatar imagePaulG ( 2017-05-19 12:02:04 +0100 )edit

that menu is in Writer, but it might effect all of LibreOffice, checking now... No, it does not affect the scrollbars in Calc... which application are you using?

librebel gravatar imagelibrebel ( 2017-05-19 12:05:29 +0100 )edit

In writer, both Horizontal and Vertical scrollbars are enabled (check-mark), but even in writer there are no scroll bars visible. (My primary usage is Calc but I use writer occassionally)

PaulG gravatar imagePaulG ( 2017-05-19 12:11:46 +0100 )edit

hmm, perhaps it has got something to do with the Theme .. are you using Elementary Theme? If so then perhaps switching to Galaxy Theme might help. You can check this in the menu "Tools : Options : LibreOffice : View " .. Else, check if you have libreoffice-gtk3 package installed

librebel gravatar imagelibrebel ( 2017-05-19 12:27:05 +0100 )edit

I know nothing about Themes. Tools:Options...:LibreOffice:View shows a bunch of stuff, but the word "Theme" does not exist. FWIW, other programs I'm using that link with gtk3 (including firefox and transmission-gtk) have no problem with the scrollbars.

What I have installed is the misc/libreoffice package from the NetBSD pkgsrc system. It was built from sources, along with all the dependencies. A package named gnome-icon-theme-3.12.0 is one of those dependencies.

PaulG gravatar imagePaulG ( 2017-05-19 12:54:21 +0100 )edit

Still wondering how to proceed on this.

And one more observation: While in Calc, I brought up the Tools->Options dialog, and selected the Internet-->EMail option. I did not already have an Email program selected, so I clicked on the Browse button and navigated to a directory where there are lots of programs, including my standard Email client. Lo and behold, the scrolling list of programs has a vertical scroll-bar!

So why no scroll bar in documents, but yes scrollbar in dialog? :)

PaulG gravatar imagePaulG ( 2017-05-28 05:49:08 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-05-19 08:43:25 +0100

Seen: 1,044 times

Last updated: May 19 '17