Ask Your Question
0

Calc: How to disable number formatting [closed]

asked 2013-01-08 15:05:17 +0200

anonymous user

Anonymous

updated 2015-10-20 00:42:00 +0200

Alex Kemp gravatar image

I'm searching for a way to disable the very annoying number formatting in Libre Office Calc. Whenever I enter some number or a string containing numbers, LO is trying to format a date out of it.

Pseudo-solutions:

I've found some so-called-solutions, but none of these works.

  • Format cells to "text" – works, but only as long as one pastes or deletes from/to a specific cell. For example, if I paste some content, the formatting is lost again.
  • Start typing with a single quote '. Not an option in daily working routine, just to enter a numeric string.
  • Deselect Tools > AutoCorrect > Options > Apply Numbering – there is no such option in Libre Office (at least not in version 3.5).

Use cases:

  • 2-3 means "two to three whatever"
  • 5.2 is the code following 5.1
  • 6. refers to the sixth item

All those values are translated to some random date in Libre Office by default. I guess they were on drugs when implementing such a bug into the program.

Is there a global setting to turn off that featurebug?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-20 00:42:22.100341

4 Answers

Sort by » oldest newest most voted
0

answered 2013-01-13 18:44:29 +0200

erAck gravatar image

updated 2013-01-13 18:44:49 +0200

Use version 3.6.2 or later, where date recognition is restricted to the current locale's date acceptance patterns and you could even edit the patterns, see https://wiki.documentfoundation.org/ReleaseNotes/3.6#Localization

edit flag offensive delete link more
1

answered 2013-01-14 03:50:50 +0200

ROSt52 gravatar image

When I look at the the examples given under "Use cases:" I wonder if Calc is the right application to be used for what Anonymus is using it.

To me it appears that a table in Writer might be the more suitable application.

edit flag offensive delete link more
0

answered 2013-01-14 00:34:20 +0200

horst gravatar image

The old 1-2-3 trick works only on formulas like 2-3. Whats the trick? Start the entry with a Blank.

edit flag offensive delete link more

Comments

Or type a leading single-quote. (Not a back-tick!!)

RonJohn63 gravatar imageRonJohn63 ( 2015-01-18 07:26:34 +0200 )edit
0

answered 2013-01-14 03:56:59 +0200

ROSt52 gravatar image

@erAck: Thanks for your hint about localization of date entries

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-01-08 15:05:17 +0200

Seen: 3,666 times

Last updated: Jan 14 '13