Calc: How to disable number formatting

I’m searching for a way to disable the very annoying number formatting in Libre Office Calc. Whenever I enter some number or a string containing numbers, LO is trying to format a date out of it.


I’ve found some so-called-solutions, but none of these works.

  • Format cells to “text” – works, but only as long as one pastes or deletes from/to a specific cell. For example, if I paste some content, the formatting is lost again.
  • Start typing with a single quote '. Not an option in daily working routine, just to enter a numeric string.
  • Deselect Tools > AutoCorrect > Options > Apply Numbering – there is no such option in Libre Office (at least not in version 3.5).

Use cases:

  • 2-3 means “two to three whatever”
  • 5.2 is the code following 5.1
  • 6. refers to the sixth item

All those values are translated to some random date in Libre Office by default. I guess they were on drugs when implementing such a bug into the program.

Is there a global setting to turn off that featurebug?

When I look at the the examples given under “Use cases:” I wonder if Calc is the right application to be used for what Anonymus is using it.

To me it appears that a table in Writer might be the more suitable application.

Use version 3.6.2 or later, where date recognition is restricted to the current locale’s date acceptance patterns and you could even edit the patterns, see

The old 1-2-3 trick works only on formulas like 2-3. Whats the trick? Start the entry with a Blank.

Or type a leading single-quote. (Not a back-tick!!)

@erAck: Thanks for your hint about localization of date entries