Japanese quoted text being formatted inconveniently

asked 2017-05-29 03:24:10 +0100

kenjitamurako gravatar image

So I want to take a crack at translating some japanese web novels and am copy-pasting them into a text editor to change the font and spacing for note taking on a physical copy. However, Libreoffice has been botching the quotation appearance as soon as I apply any formatting changes to the pasted text. Images for reference: Pre-formatted Post formatted

The block quotes are automatically being changed from encapsulating the text to just appearing at the end. This makes it much more difficult to identify quoted text and is a pain in the butt to manually go through a document to correct every instance of quotes being changed. Is there a setting I can change to stop this from happening? This doesn't happen in Microsoft Wordpad but I'd prefer to stick with LibreOffice for everything if possible.

Using Windows 10 x64 with LibreOffice 5.1.1.3

edit retag flag offensive close merge delete

Comments

I can't reproduce this with LibreOffice 5.0.2.1 on Windows 7 doing as follows:

  1. Paste a line of text from the Mitsui site (or any other site in Japanese).

  2. Enclose the text into the quotation marks of 「」.

  3. The font is set automatically to SimSun. I change it to MS PMincho, MS UI Gothic, Dotum, and the quotation marks remain in place.

Note that I paste unformatted text.

gabix gravatar imagegabix ( 2017-05-29 09:22:45 +0100 )edit

Also can't reproduce this with LO5.4 on Ubuntu. One thing that sticks out in your screenshots is the difference in font. Try resetting the formatting (ctrl+m), changing the font, or pasting unformatted text as mentioned by @gabix.

KH gravatar imageKH ( 2017-11-02 03:31:07 +0100 )edit