Ask Your Question
0

Disable macro security warning in Calc

asked 2017-06-02 15:07:10 +0200

Evgeny.M gravatar image

When I load an .xls spreadsheet into LibreOffice, I get the following dialog: "This document contains macros. Macros may contain viruses. Execution of macros is disabled due to the current macro security setting in Tools - Options - LibreOffice - Security. Therefore, some functionality may not be available." Is it possible to disable this dialog, i.e., not see any warning when I load similar files?

The option in Tools | Options | Security | Macro Security is set to High. In Tools | Options | Security | Security Options and Warnings the following are set: "When signing" and "Ctrl-click required to follow links".

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-06-03 00:43:23 +0200

Ratslinger gravatar image

On the same dialog where you set 'Security' to 'High', select the Trusted Sources tab at the top, then use the Trusted File Locations section to add the folder where your calc files resides.

If this answers your question please click on the ✔ (upper left area of answer).

edit flag offensive delete link more

Comments

But this makes LibreOffice run the macros, doesn't it? I just want to disable the modal warning, not run other people's code on my machine!

phihag gravatar imagephihag ( 2017-10-20 23:14:59 +0200 )edit

Don't see a way to disable both Dialog & Macros completely.

Ratslinger gravatar imageRatslinger ( 2017-10-20 23:26:09 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2017-06-02 15:07:10 +0200

Seen: 1,085 times

Last updated: Jun 03 '17