Disable macro security warning in Calc

When I load an .xls spreadsheet into LibreOffice, I get the following dialog: “This document contains macros. Macros may contain viruses. Execution of macros is disabled due to the current macro security setting in Tools - Options - LibreOffice - Security. Therefore, some functionality may not be available.” Is it possible to disable this dialog, i.e., not see any warning when I load similar files?

The option in Tools | Options | Security | Macro Security is set to High. In Tools | Options | Security | Security Options and Warnings the following are set: “When signing” and “Ctrl-click required to follow links”.

On the same dialog where you set ‘Security’ to ‘High’, select the Trusted Sources tab at the top, then use the Trusted File Locations section to add the folder where your calc files resides.

If this answers your question please click on the :heavy_check_mark: (upper left area of answer).

1 Like

But this makes LibreOffice run the macros, doesn’t it? I just want to disable the modal warning, not run other people’s code on my machine!

Don’t see a way to disable both Dialog & Macros completely.