Ask Your Question
0

Docs being saved as "Text Edit"

asked 2017-06-05 12:14:42 +0200

Sioned Cati gravatar image

How do I stop all docs being saved as "Text Edit"?

I've re-downloaded Libre Office but it's still happening.

Mac.

Includes docs exported as pdfs.

Thanks! :)

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-06-06 07:33:24 +0200

gtomorrow gravatar image

Are you saving your Writer files as .odt files? If so, it's not a LibreOffice problem, per se. In Finder select your Writer document and go to "File > Get Info" (or press Cmd-i). In the Get Info window's "Open With" section, click the drop-down list (it probably says "TextEdit.app" at this point) and choose "LibreOffice.app", then click the "Change All" checkbox. Finder will ask you to confirm. After that all your Writer docs should open in LibreOffice automatically.

If you are saving your Writer documents as .txt, know that macOS is set to open all .txt files in TextEdit. You can either accept this and use "Open With..." to open selected files in LibreOffice or change all .txt files to be opened in LibreOffice with the same method above. But all your .txt files, regardless of the app used to create them, will then open in LibreOffice.

I'm not sure why your PDFs are opening in TextEdit but using the same "Change All" method you should be able to set "Preview" or "Adobe Acrobat" as your default PDF app.

edit flag offensive delete link more

Comments

Many thanks! That seems to be doing the trick - really appreciate your detailed instructions :)

Sioned Cati gravatar imageSioned Cati ( 2017-06-06 15:50:27 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-06-05 12:14:42 +0200

Seen: 330 times

Last updated: Jun 06 '17