Ask Your Question
2

Change template associated with a document

asked 2013-01-14 11:47:29 +0200

ak40139 gravatar image

In Libre Writer, Properties/General view shows the current template associated with the document. How can I change this, in LO?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
2

answered 2013-01-30 22:34:59 +0200

razon_22 gravatar image

updated 2013-03-14 04:43:14 +0200

The Template Changer extension can be used to change the template currently associated with a document. It will allow you to change one or several files at a time. The Template Changer extension can be downloaded here.

It's currently compatible with LibreOffice 3.4 thru 3.6. More information on how to use it is available here.

LibreOffice 4 users can see this question.

edit flag offensive delete link more

Comments

manj_k gravatar imagemanj_k ( 2013-03-14 10:15:18 +0200 )edit

The extension can be a good solution. Unfortunately it does not work with LO 4.0 or 4.1. Is there another way how to change the document template?

imcon gravatar imageimcon ( 2013-09-13 21:48:51 +0200 )edit
1

@imcon The Template Changer extension on templates.libreoffice.org is version 1.2.6 and only works with 3.x versions of LibreOffice. Version 1.2.7b of the extension is available. It's a beta version that does work with 4.0 and later. Follow the link @manj_k posted in a comment to this answer. There he provides some important info about it and provides a link to the bug where the extension is posted.

Here is the direct link for the beta version of the extension from @manj_k's post (let's give László some thanks for his work on this!):

László Németh 2013-06-14 13:47:10 UTC

This beta release contains the necessary fixes for LibreOffice 4 ...(more)

razon_22 gravatar imagerazon_22 ( 2013-09-14 03:02:51 +0200 )edit
1

answered 2018-04-25 18:43:42 +0200

Fuzzi gravatar image

I don't know about the benefits, but latest version is 1.2.7d (my mirrored file on dropbox) from 2016-10-17.

Original file from the bugtracker (attatchment in comment 16) has to be renamed from .zip to .oxt if you want to install under windows.

edit flag offensive delete link more
0

answered 2016-02-22 10:45:53 +0200

David gravatar image

Note that the template-changer-1.2.7c.oxt version of the extension (not the version available in the LibO Extensions repository) still works well with LibO Writer Version: 5.0.2.2.

This is an important extension, so it's a shame that it isn't updated in the official repo.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2013-01-14 11:47:29 +0200

Seen: 2,937 times

Last updated: Apr 25 '18