Haz tu Pregunta
1

Obtener lista tras validación y realizar doble validación.

preguntado 2014-10-01 17:26:30 +0100

Imagen Gravatar de nicolasnu

Tengo una hoja con las siguientes columnas

ID / DESCRIPCION - PROVEDOR - PRECIO

Para cada ID hay una única descripción, pero pueden haber múltiples proveedores y múltiples precios.

Estoy teniendo problemas con DOS funciones:

  1. Extraer la lista de proveedores en función del ID seleccionado.

Esa función, me ayudaría a obtener los n proveedores que hay para cada ID. Es para ingresarla dentro de una lista desplegable de validación.

  1. "doble buscarv", la idea de ésto es la siguiente:

Selecciono ID y en la celda siguiente (donde ingresé la función anterior) selecciono el proveedor; en la "tercer" celda "busca" el valor correspondiente a la ID y a ESE proveedor y me devuelve al PRECIO.

Muchas gracias por su colaboración

edit re-etiquetar marcar como ofensivo cerrar fusionar delete

Comments

Por favor sube un ejemplo con indicaciones. (Te he votado la pregunta para que puedas subir el fichero)

Imagen Gravatar de m.a.riosv m.a.riosv ( 2014-10-02 01:35:08 +0100 )edit
Imagen Gravatar de nicolasnu nicolasnu ( 2014-10-06 15:44:50 +0100 )edit

1 Responder

Ordenar por » viejos nuevas más votado
1

respondido 2014-10-06 22:20:09 +0100

Imagen Gravatar de m.a.riosv

Adjunto el fichero de ejemplo con nueva formulación, que espero seas lo que estabas buscando. ValidezDatosCombinada+EncontrarDobleCondición.ods

En F3 para la validación de datos seleccionando rango de celdas: SI($E3=$A$3:$A$10;$B$3:$B$10)

Para encontrar el precio en G3: =SUMAR.SI.CONJUNTO($C$3:$C$10;$A$3:$A$10;$E3;$B$3:$B$10;$F3)

edit marcar como ofensivo delete enlace mas

Comments

Te super super super agradezco ! Me has resuelto un montón de dolores de cabeza ! Muchas gracias !

Imagen Gravatar de nicolasnu nicolasnu ( 2014-10-16 16:36:09 +0100 )edit
Ingresa/Regístrate para Contestar

Herramientas de Preguntas

1 seguidor

Estadisticas

Preguntado: 2014-10-01 17:26:30 +0100

Visto: 246 veces

Ultima actualización: Oct 06 '14