Poser votre question
0

Fonction "SI" ne fournit pas le résultat attendu [fermée]

posée 2019-01-10 15:40:01 +0200

Image Gravatar de Larocom

updated 2019-01-10 15:45:34 +0200

Bonjour, J'ai un classeur "Furets_Calc mailing.ods" contenant 3 feuilles. La feuille 3 supporte 2 cellules: A1 a la valeur "2019" et B1 a la valeur "Certificat médical obligatoire".

Dans la feuille 1, je réfère à ces 2 précédentes cellules au travers de la fonction "SI" incluse dans la cellule "K2" et qui s'appuie sur la cellule "J2" contenant la valeur "2016": =SI(J2+3=$Feuille3.A1;$Feuille3.B1;"").

Dans "K2", au lieu de la valeur attendue "Certificat médical obligatoire" j'obtiens l'affichage de la formule =SI(J2+3=$Feuille3.A1;$Feuille3.B1;"").

Le format de "J2" est de type "nombre", celui de "K2" est de type "texte".

Pourquoi un tel comportement de la fonction "SI" avec LibreOffice alors que sous EXCEL 365 cela fonctionne ? D'avance merci de votre aide.

éditer requalifier signaler réouvrir fusionner supprimer

Fermé pour la raison suivante Question en doublon par Larocom
date de clôture 2019-01-11 08:45:52.623679

1Réponse

0

répondue 2019-01-10 16:43:54 +0200

Image Gravatar de pierre-yves samyn

Bonjour

Ce que tu décris se produit quand la cellule contenant la formule a été formatée en texte.

Dans l'exemple joint

  • en A1 tu obtiens le résultat (formatage par défaut avant saisie de la formule)
  • en B1 tu obtiens ce que tu décris (formatage texte avant saisie de la formule).

Cordialement

éditer signaler supprimer permalien plus

Commentaires

Bonjour,

Merci pour ta réponse qui m'offre la solution. J'avoue ne pas avoir eu l'idée de déclarer numérique une cellule recevant du contenu alpha.

Bien cordialement.

Image Gravatar de LarocomLarocom ( 2019-01-11 08:44:08 +0200 )éditer

Outils de question

1 suiveurs

Stats

Posée: 2019-01-10 15:40:01 +0200

Consultée: 27 fois

Mise à jour: Jan 11