Poser votre question
0

option _parent dans export html

posée 2019-04-06 11:28:37 +0200

Bonjour, J'utilise beaucoup la fonction export Html, pour rendre consultable en ligne des textes que je travaille sur writer. Mais l'option d'ouverture des liens (_parent ou _blank…) n'est pas conservée lors de l'exportation. Je suis au courant que ces consignes peuvent être interprêtées de manière diverse par les navigateurs, mais là le lien ne comporte aucune option dans le code html généré par l'exportation :

<body dir="ltr" style="max-width:21.001cm;margin-top:2cm; margin-bottom:2cm; margin-left:2cm; margin-right:2cm; ">

Lien vers le site du Parisien, censé s’ouvrir dans une nouvelle fenêtre.

</body>

(produit à partir du fichier ci-joint). Je travaille sur LibreOffice Version: 5.4.4.2, sous mac OS version 10.14

Merci d'avance pour votre aide. Cordialement, Vincent

C:\fakepath\TestLien.odt

éditer requalifier signaler fermer fusionner supprimer

2Réponses

0

répondue 2019-04-07 07:29:54 +0200

Image Gravatar de pierre-yves samyn

updated 2019-04-07 09:43:24 +0200

Bonjour

Plusieurs choses que je ne comprends pas dans ta question :

  • le lien du document joint est défini sur target="_parent"
  • ceci est bien conservé lors de l'enregistrement .html (dans mon environnement).
  • cf. les spécifications ceci est prévu pour ne pas ouvrir de nouvelle fenêtre.
  • l'utilisation à la place de _blank est bien conservée lors l'export et fonctionne comme attendu...

[Ajout]

Avec les nouveaux éléments (document joint conforme à ce qui est annoncé et format généré) je comprends mieux... tu utilises l'export xhtml et non l'enregistrement sous html qui, toujours dans mon environnement, préserve l'attribut target.

Le bug avait été remonté mais pas suivi par son auteur. Tu utilises également une version ancienne ; aurais-tu l'opportunité de tester avec une plus récente ?

Sinon, sur la forme, sur ce site il est conseillé de privilégier la fonction éditer ou ajouter un commentaire pour apporter des précisions plutôt que d'utiliser la fonction Répondre.

Cordialement

éditer signaler supprimer permalien plus
0

répondue 2019-04-07 08:22:13 +0200

updated 2019-04-08 17:55:22 +0200

Merci pour ta réponse. J'ai bien compris les spécifications, mais dans mon environnement, même l'option blank n'est pas conservée lors de l'exportation. Je ne peux pas attacher de fichier html, mais je te colle ci-dessous le code html produit, et le fichier odt d'origine. Après, je peux aussi copier-coller tout le texte dans un fichier html vierge ouvert depuis LibreOffice, là l'option "blank" est bien conservée. Mais dans la fonction "export", pour moi il y a un bug. Amicalement, VP

C:\fakepath\TestLien.odt

<html xmlns="http://www.w3.org/1999/xhtml"> <head profile="http://dublincore.org/documents/dcmi-terms/"> <meta http-equiv="content-type" content="text/html; charset=utf-8"> <title xml:lang="en-US">- no title specified</title> <meta name="DCTERMS.title" content="" xml:lang="en-US"> <meta name="DCTERMS.language" content="en-US" scheme="DCTERMS.RFC4646"> <meta name="DCTERMS.source" content="http://xml.openoffice.org/odf2xhtml"> <meta name="DCTERMS.creator" content="Vincent Planel"> <meta name="DCTERMS.issued" content="2019-04-06T10:40:04.195288115" scheme="DCTERMS.W3CDTF"> <meta name="DCTERMS.contributor" content="Vincent Planel"> <meta name="DCTERMS.modified" content="2019-04-07T08:16:03.950039633" scheme="DCTERMS.W3CDTF"> <meta name="DCTERMS.provenance" content="" xml:lang="en-US"> <meta name="DCTERMS.subject" content="," xml:lang="en-US"> <link rel="schema.DC" href="http://purl.org/dc/elements/1.1/" hreflang="en"> <link rel="schema.DCTERMS" href="http://purl.org/dc/terms/" hreflang="en"> <link rel="schema.DCTYPE" href="http://purl.org/dc/dcmitype/" hreflang="en"> <link rel="schema.DCAM" href="http://purl.org/dc/dcam/" hreflang="en"> <style type="text/css"> @page { } table { border-collapse:collapse; border-spacing:0; empty-cells:show } td, th { vertical-align:top; font-size:12pt;} h1, h2, h3, h4, h5, h6 { clear:both;} ol, ul { margin:0; padding:0;} li { list-style: none; margin:0; padding:0;} /* "li span.odfLiEnd" - IE 7 issue/ li span. { clear: both; line-height:0; width:0; height:0; margin:0; padding:0; } span.footnodeNumber { padding-right:1em; } span.annotation_style_by_filter { font-size:95%; font-family:Arial; background-color:#fff000; margin:0; border:0; padding:0; } span.heading_numbering { margin-right: 0.8rem; } { margin:0;} .P1 { font-size:12pt; font-family:Times New Roman; writing-mode:page; text-align:justify ! important; } .Internet_20_link { color:#000080; text-decoration:underline; } .T1 { font-style:normal; } .T2 { font-style:normal; } /* ODF styles with no properties representable as CSS */ { } </style> </head> <body dir="ltr" style="max-width:21.001cm;margin-top:2cm; margin-bottom:2cm; margin-left:2cm; margin-right:2cm; ">

Voici un lien vers le site du Parisien, comportant l’option « _blank », censé s’ouvrir dans une nouvelle fenêtre.

</body> </html>


OK, en passant par "Enregistrer sous", et en choisissant le format html, ça marche. Merci pour votre aide! Cordialement.

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2019-04-06 11:28:37 +0200

Consultée: 14 fois

Mise à jour: Apr 08