Fai la tua domanda
0

writer 5.3 non si avvia (ubuntu 14.04)

chiesto il 2017-07-04 03:09:16 +0100

Immagine gravatar per Canny

updated 2017-07-04 03:27:01 +0100

buona sera Writer 5.3 su Ubuntu 14.04 (kernel 4.4.0-83) non si avvia; se apro il launcher principale tutto ok ma una volta selezionato nuovo documento di writer chrasha subito; se lo avvio da terminale non mi compare niente che possa aiutarmi; il programma chrasha e ritorna il prompt dei comandi; chrasha anche se lo avvio in modalità sicura; ho provato anche a rinominare la cartella libreoffice dentro la cartella .config in modo da avere impostazioni nuove ma senza nessun risultato. Writer non si avvia; Calc, Draw, Impress si avviano senza problemi; proprio non capisco...

modifica retag flag offensive close merge delete

3 Answers

0

risposto il 2017-07-06 13:39:29 +0100

updated 2017-07-06 13:42:05 +0100

Ciao, il mio consiglio è quello di eliminare la cartella userdel profilo utente come da queste indicazioni: https://ask.libreoffice.org/it/questi...

Se non dovesse funzionare, non resta che disinstallare LO e procedere con una nuova installazione.

Se la mia riposta ti ha aiutato, votala con ✔ (qui a sinistra)

modifica flag offensive delete link more

Commenti

Grazie delle indicazioni, ma tentate entrambe e... fa lo stesso!

Immagine gravatar per Walter_P Walter_P ( 2017-07-06 14:52:17 +0100 )modifica

Allora io proverei una versione precedente di LO, nell'ipotesi di un bug.

Immagine gravatar per charlie.it charlie.it ( 2017-07-06 22:23:13 +0100 )modifica

Ciao, buongiorno e grazie delle dritte! Dunque, disinstallata la 5.3 ("purgato" tutto), installata la 5.2.7 Tutto ha ripreso a funzionare correttamente. Non contento, disinstallata la 5.2.7 e reinstallata la 5.3, il sistema torna nuovamente a bloccarsi su Writer. Ritorno quindi alla 5.2.7. Grazie di nuovo!!!!

Immagine gravatar per Walter_P Walter_P ( 2017-07-07 08:58:31 +0100 )modifica

Dunque: un possibile bug?

Bisognerebbe segnalarlo qui: https://bugs.documentfoundation.org//

Se la mia riposta ti ha aiutato, votala con ✔

Immagine gravatar per charlie.it charlie.it ( 2017-07-07 11:30:21 +0100 )modifica
0

risposto il 2017-07-06 10:33:19 +0100

Buongiorno, scusate se mi "accodo" qui, ma ho lo stesso identico problema - LUBUNTU 17.4 e Writer 5.3. Il CALC si avvia senza problemi, ma il Writer fa un flash e basta! Help PLS! Saluti, Walter

modifica flag offensive delete link more

Commenti

ciao, avvia calc e vedi se è inserita la spunta in opzioni>generali>Avanzate sull'uso di java; prova a toglierla e vedi se Writer si avvia; sul mio sistema ha avuto successo

Immagine gravatar per Canny Canny ( 2017-07-10 08:34:34 +0100 )modifica
0

risposto il 2017-07-09 23:34:54 +0100

Immagine gravatar per Canny

updated 2017-07-09 23:36:41 +0100

Avevo già provato a eliminare user ma senza successo. Poi ho disinstallato Writer è l'ho reinstallato ma il problema persisteva allora ho disinstallato (opzione purge) e reinstallato tutto Libreoffice ma ancora niente da fare: Writer si ostinava a non avviarsi. ho provato a fare debug ma purtroppo non è andata in quanto i pacchetti richiesti presenti sulla mia versione di ubuntu erano troppo vecchi. Ho provato anche con strace ma non ne ho ricavato molto; sembra che avviando writer si producesse un SIGFAULT in quanto javaVM era incapace di avviarsi; quindi invece di usare java 8 di oracle ho provato a usare open-jdk ma sempre senza risultato; reinstallare una versione precedente non era un'opzione per me perché mi servono delle feature che sono state introdotte dalla 5.3 per cui ho installato Libreoffice 5.4 RC1 e Writer funziona; nonostante però i lanciatori della 5.4 siano correttamente posizionati nella cartella /usr/share/applications, se blocco le icone di LO5.4 su Unity alla successiva apertura il lanciatore richiama invece libreoffice 5.3 mentre se avvio facendo la ricerca del programma dalla dash si avvia la versione desiderata (LO5.4)

modifica flag offensive delete link more

Commenti

Dopo aver installato la 5.4 ho confrontato le due versioni delle cartella user e ho notato che in quella della 5.3 c'era un file .lock che nella 5.4 non c'era. Comunque a farla breve nella 5.3 il comportamento anomalo di Writer era causato dall'essere spuntato nella sezione Avanzate di Opzioni l'uso della macchina Java: non importa quale fosse selezionata (sul mio sistema ne ho tre) se era spuntata l'opzione di utilizzo, Writer non si avviava. Tolta la spunta avviando Calc tutto è andato ok.

Immagine gravatar per Canny Canny ( 2017-07-10 08:26:30 +0100 )modifica

Sulla versione 5.4 invece Writer funziona sempre sia che ci sia la spunta sull'uso di Java in Opzioni>Avanzate, sia con tutte le versioni di java presenti sulla mia macchina , sia senza spunta; adesso quindi mi resta da capire perché. anche perché cancellando la cartella user della 5.3 quando è spuntata l'opzione di utilizzo java quella che si crea ex novo ha le stesse caratteristiche; e succedeva anche eliminando l'intera cartella libreoffice da .config

Immagine gravatar per Canny Canny ( 2017-07-10 08:28:35 +0100 )modifica

Java non viene utilizzato da Writer, quindi è indifferente che ci sia o no la spunta. Java serve principalmente per Base e per la Stampa guidata in serie.

Immagine gravatar per charlie.it charlie.it ( 2017-07-10 09:33:23 +0100 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2017-07-04 03:09:16 +0100

Seen: 754 times

Last updated: Jul 09 '17