We will be migrating from Ask to Discourse on the first week of August, read the details here

Fai la tua domanda
0

Cercare differenze tra due colonne

chiesto il 2018-10-05 20:05:58 +0200

Immagine gravatar per liberouff

updated 2018-10-05 20:06:31 +0200

Buonasera a tutti, non sono molto pratico di Calc però ho la seguente esigenza:

ho due colonne (A e B) come si vede nel file allegato.

Devo estrarre, dalla colonna A, tutti i numeri che NON sono presenti nella colonna B per poi ottenere un'unica colonna. Come si procede? Grazie mille! C:\fakepath\test.ods

modifica retag flag offensive close merge delete

2 Answers

0

risposto il 2018-10-06 20:47:21 +0200

Immagine gravatar per gioh66

updated 2018-10-07 08:32:05 +0200

Buona sera, potresti provare con questa formula matriciale (CTRL+MAIUSCOLO+INVIO per confermarla) da mettere in cella C2 e da copiare in basso. Per libreoffice

=SE.ERRORE(INDICE($A$2:$A$9;PICCOLO(SE(CONTA.SE($A$2:$A$9;$B$2:$B$7)<1;RIF.RIGA($A$2:$A$9)-1);RIF.RIGA($A1)));"")

se invece hai openoffice

=SE(VAL.ERRORE(INDICE($A$2:$A$9;PICCOLO(SE(CONTA.SE($A$2:$A$9;$B$2:$B$7)<1;RIF.RIGA($A$2:$A$9)-1);RIF.RIGA($A1))));"";INDICE($A$2:$A$9;PICCOLO(SE(CONTA.SE($A$2:$A$9;$B$2:$B$7)<1;RIF.RIGA($A$2:$A$9)-1);RIF.RIGA($A1))))

C:\fakepath\duplicati.ods

modifica flag offensive delete link more

Commenti

non mi trovo però: nel tuo file con la formula vengono inseriti, nella colonna C, due numeri (346 e 567856) che sono presenti nella colonna B e quindi non avrebbero dovuto essere portati.

Immagine gravatar per liberouff liberouff ( 2018-10-07 09:30:24 +0200 )modifica

Hai ragione non mi sono accorto che la formula estrae anche due dati duplicati. Rileggendo poi il primo messaggio mi è venuto un dubbio: tu vuoi ottenere un'unica colonna da A e B senza duplicati? Se è così prova questa formula, sempre matriciale, in D2 metti

=SE.ERRORE(INDIRETTO("r" & SOSTITUISCI(TESTO(MIN(SE(CONTA.SE($A$2:$B$9;$A$2:$B$9)>=1;SE($A$2:$B$9<>"";SE(CONTA.SE(D$2:D2;$A$2:$B$9)=0; RIF.RIGA($A$2:$B$9)+RIF.COLONNA($A$2:$B$9)/1000))));"#,000"); ","; "C");0);"")

per libreoffice,

Immagine gravatar per gioh66 gioh66 ( 2018-10-07 21:00:54 +0200 )modifica

Se usi openoffice invece metti

=SE(VAL.ERRORE(INDIRETTO("r" & SOSTITUISCI(TESTO(MIN(SE(CONTA.SE($A$2:$B$9;$A$2:$B$9)>=1;SE($A$2:$B$9<>"";SE(CONTA.SE(D$2:D2;$A$2:$B$9)=0; RIF.RIGA($A$2:$B$9)+RIF.COLONNA($A$2:$B$9)/1000))));"#,000"); ","; "C");0));"";INDIRETTO("r" & SOSTITUISCI(TESTO(MIN(SE(CONTA.SE($A$2:$B$9;$A$2:$B$9)>=1;SE($A$2:$B$9<>"";SE(CONTA.SE(D$2:D2;$A$2:$B$9)=0; RIF.RIGA($A$2:$B$9)+RIF.COLONNA($A$2:$B$9)/1000))));"#,000"); ","; "C");0))

Ovviamente devi adattare la formula al tuo file.

Immagine gravatar per gioh66 gioh66 ( 2018-10-07 21:03:20 +0200 )modifica
0

risposto il 2018-10-06 10:44:10 +0200

Immagine gravatar per biagio.ferrara

updated 2018-10-07 21:21:59 +0200

potresti provare a fare una colonna unica dopodiché dal menu : DATI -> ALTRI FILTRI ->FILTRO SPECIALE -> OPZIONI NESSUN DUPLICATO .

Ti allego le schermate.

C:\fakepath\Schermata dopo il filtro 2018-10-07 19-48-04.png C:\fakepath\Schermata prima del filtro 2018-10-07 19-47-42.png

modifica flag offensive delete link more

Commenti

abbi pazienza ma non ho capito un paio di cose:

1 ho fatto come in questa immagine: https://imgur.com/a/Khbo9Om ma non succede nulla. Dove sbaglio?

2 come farò poi a sapere quali numeri saranno stati scartati perchè duplicati?

Immagine gravatar per liberouff liberouff ( 2018-10-06 11:36:36 +0200 )modifica

Ri-leggi la mia risposta e guarda gli allegati che ho aggiunto.

Immagine gravatar per biagio.ferrara biagio.ferrara ( 2018-10-07 21:12:11 +0200 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2018-10-05 20:05:58 +0200

Seen: 1,242 times

Last updated: Oct 07 '18