Fai la tua domanda
0

Riportare cella corrispondete a valore MAX

chiesto il 2019-01-24 12:22:10 +0200

Immagine gravatar per ciocci

Buongiorno, sono ancora a chiedere un consiglio. Avrei bisogno di una funzione che mi riporti il contenuto di testo della cella corrispondente (spostata in orizzontale) al valore massimo di un intervallo di valori.

Spero di essere stato chiaro. Allego file di riferimento.

Grazie mille.C:\fakepath\esempio max.ods

modifica retag flag offensive close merge delete

Commenti

In realtà dovrebbe essere abbastanza semplice con cerca.vert, ma le ho provate tutte e non ci riesco..

Immagine gravatar per ciocci ciocci ( 2019-01-24 12:32:39 +0200 )modifica

4 Answers

1

risposto il 2019-01-24 13:04:10 +0200

Immagine gravatar per R.C.

Innanzitutto ti conviene far ripetere i valori della colonna C in colonna A (che puoi in seguito escludere dall'area di stampa o nascondere del tutto). Ciò ti consentirà di usare CERCA.VERT per recuperare il valore in colonna B che ti serve. Nella posizione reciproca in cui sono ora, dovresti combinare CONFRONTA e CERCA.ORIZZ, che è più complicato.

Per individuare il valore massimo utilizzi la funzione GRANDE: la sua sintassi, nel tuo file di esempio (dopo l'accorgimento di cui sopra), sarà =GRANDE(A5:A13;1), vale a dire "cerchi nell'area A5:A13 il valore al 1° posto per grandezza".

Poi ti posizioni nella cella dove vuoi il tuo massimo, e imposti CERCA.VERT così: =CERCA.VERT(GRANDE(A5:A13;1);A5:B13;2;0), vale a dire "cerchi il risultato della funzione GRANDE nella colonna A dell'area A5:B13, ti sposti nella seconda colonna e mi riporti esattamente quel che ci trovi".

AVVERTENZA: se il valore massimo ricorresse due o più volte, ti verrebbe segnalato solo il primo caso.

modifica flag offensive delete link more
0

risposto il 2019-01-24 23:43:51 +0200

Immagine gravatar per ciocci

Grazie a tutti. La prima formula mi sembra la più semplice ed efficace.

Siete dei mostri (buoni) come sempre :)

modifica flag offensive delete link more
0

risposto il 2019-01-24 18:13:40 +0200

Immagine gravatar per gioh66

updated 2019-01-24 20:09:44 +0200

Salve una formula alternativa può essere

=INDICE(B5:B13;CONFRONTA(MAX(C5:C13);C5:C13;0))

Oppure se ci fossero più valori massimi potresti usare

=SE(RIGHE($E$5:E5)>CONTA.SE($C$5:$C$13;MAX($C$5:$C$13));"";INDICE($B$5:$B$13;CONFRONTA(GRANDE($C$5:$C$13;RIF.RIGA($A1));$C$5:$C$13;0)))

e tirare in basso. Questa formula ti mostra solo i valori di colonna B che corrispondono al massimo di colonna C.

modifica flag offensive delete link more
0

risposto il 2019-01-25 10:47:54 +0200

Immagine gravatar per akurery

Altra possibile alternativa:

=CERCA(MAX(C5:C13);C5:C13;B5:B13)

in caso di più valori massimi uguali, restituisce il Nome dell'ultimo.

modifica flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2019-01-24 12:22:10 +0200

Seen: 65 times

Last updated: Jan 25