Fai la tua domanda
0

Conteggio nomi

chiesto il 2019-12-04 13:24:07 +0100

Immagine gravatar per Mick80

Buongiorno a tutti,

Vorrei creare una tabella per calcolare i presenti di una assemblea condominiale. Ho creato una lista con tutte le porzioni materiali del condominio (appartamenti, garages, cantine, ecc…). Ogni porzione è associata a un proprietario e ha un valore in millesimi. Il totale dei millesimi di tutte le porzioni è 1000. Fin qui nessun problema.

Adesso devo calcolare il numero dei proprietari considerando però che un proprietario può avere più porzioni (ad esempio può avere l'appartamento n.70 e il garage n.145) e che quindi comparirà più volte nell'elenco.

Ho provato con i subtotali e va bene a metà, nel senso che mi raggruppa le porzioni di ogni proprietario e mi calcola i millesimi complessivi di ognuno (esempio: proprietario X ha l'appartamento n.70 millesimi 12,000 e il garage n.145 millesimi 1,500; totale millesimi proprietario X = 13,500) ma non so come contare quanti sono i proprietari.

Sicuramente c'è un modo semplice per farlo in automatico ma non mi viene in mente niente, qualcuno sa farlo?

Grazie in anticipo!

modifica retag flag offensive close merge delete

3 Answers

0

risposto il 2019-12-04 15:45:06 +0100

Immagine gravatar per R.C.

Se ho ben capito, tu hai già sul PC un elenco in Calc delle unità immobiliari del condominio, ciascuna con i suoi millesimi e il nome del proprietario.

Fanne una copia (se non vuoi alterare l'originale) e dagli un ordinamento in base alla colonna dove c'è il nome del proprietario (supponiamo che sia la colonna B, e che l'elenco parta dalla cella B2).

Spostati in una colonna vuota, preferibilmente separata dall'elenco (per ipotesi la E) e nella cella E2 imposta la funzione SE in questo modo:

=SE(B2<>B1;B2;"")

cioè: se il nome del proprietario, scritto in B2, è diverso da quello in B1, riporta quel nome, altrimenti lascia vuota la cella.

Trascina la funzione lungo tutto l'elenco, poi fai un Copia-Incolla speciale: valori per eliminare la funzione; infine ordina la colonna E, in modo che i nomi si raggruppino insieme e le celle vuote finiscano tutte in fondo all'elenco. Avrai così l'elenco completo dei proprietari, in ordine alfabetico, e ti basterà contare quante righe occupi per saperne il numero, (A dire il vero, però, mi sorprende che tu non abbia già un elenco dei condomini, e lo debba ricavare da Calc: come sono state fatte, finora, le convocazioni delle assemblee condominiali?).

Per sapere i millesimi totali di ogni proprietario, io avrei utilizzato la funzione SOMMA.SE invece dei subtotali, che irrigidiscono l'elenco.

Se la mia risposta ti ha aiutato, votala con ✔ (qui a sinistra)

modifica flag offensive delete link more
0

risposto il 2019-12-06 10:43:58 +0100

Immagine gravatar per Mick80

Finora ho usato un elenco molto più semplice in cui a mano ho inserito l'elenco dei proprietari e a fianco le unità associate e i relativi millesimi, ma non mi ha mai convinto del tutto perché in caso di votazione non riesco a separare le unità di ogni proprietario (per esempio un proprietario può avere un appartamento nella scala A e uno nella scala C, e vorrei poter filtrare l'elenco per scala o altro).

Appena posso provo le due soluzioni proposte e vi faccio sapere, grazie mille per l'aiuto!

modifica flag offensive delete link more

Commenti

Ti basterebbe aggiungere nuove colonne al tuo elenco, con la scala o gli altri dati che vorresti poter usare come filtro. Se hai già questi dati in altri file (ad es. le unità immobiliari divise per scala) puoi evitare di farlo manualmente: basta ricorrere a funzioni opportunamente scelte, ad es. CERCA.VERT e/o SE (dipende da come sono organizzati i dati che già possiedi). Poni eventualmente un nuovo quesito.

Immagine gravatar per R.C. R.C. ( 2019-12-06 12:33:07 +0100 )modifica
0

risposto il 2019-12-04 15:51:37 +0100

Immagine gravatar per gioh66

Salve senza un file, azzardo un'ipotesi. Mettiamo che i nomi degli inquilini siano nel range A1:A22, in una cella prova così

=MATR.SOMMA.PRODOTTO(1/CONTA.SE(A1:A22;A1:A22))

modifica flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2019-12-04 13:24:07 +0100

Seen: 28 times

Last updated: Dec 06