Fai la tua domanda
0

Ordinare dati - PROBLEMA

chiesto il 2020-02-07 11:41:33 +0100

Immagine gravatar per Marta2912

Buongiorno a tutt*, non è la prima volta che incappo in questo problema, ogni volta risolvo manualmente ma vorrei riuscire a capire dove sta l'inghippo.

Inserisco dei dati in varie righe/colonne: GIORNO - IMPORTO 01 100 03 120 12 90

le celle "GIORNO" sono tutte formattate nello stesso modo (tentato sia come numero/standard, sia numero/-1234,57, sia testo/@) ma nel momento in cui seleziono tutte le celle e le metto in ordine crescente/decrescente, una selezione resta fuori posto.

Esempio di oggi, con le prime 7 celle in oridne tra di loro e poi le altre a seguire in oridne tra di loro

descrizione immagine

Grazie a chi mi riuscirà ad illuminare :D

modifica retag flag offensive close merge delete

Commenti

Per favore, allega un file, dall'immagine non si capisce nulla. Poi, perché il giorno non lo formatti a data?

Immagine gravatar per R.C. R.C. ( 2020-02-07 14:55:05 +0100 )modifica

3 Answers

0

risposto il 2020-02-08 11:09:44 +0100

Immagine gravatar per Marta2912

updated 2020-02-12 17:23:02 +0100

Immagine gravatar per akurery

C:\fakepath\1581502288695348-2.ods

Ecco il file. E' la colonna con le celle non in ordine, nonostante le abbia selezionate tutte e abbiamo impostato ordine crescente.

Mi serve che ci sia soloi l numero di giorno, non anche mese e anno, e comunque selezionando il formato data "WW", non mette comunque utte le celle in ordine, ne lascia una parte "sfasata". Non riesco a capire il problema

EDIT 12/02

Ecco, questo è il file. Ho formattato come testo. perchè non c'è nessun formato data che preveda solo il numero del giorno come serve a me.

modifica flag offensive delete link more

Commenti

Salve! Hai ri-allegato un'immagine. Se vuoi aiuto allega un file .ods, senza eventuali dati sensibili, da poter esaminare e farci delle prove.

Immagine gravatar per gioh66 gioh66 ( 2020-02-08 17:59:56 +0100 )modifica

Ciao, ho sostituito il tuo file perchè avevi lasciato i fogli dietro con nominativi ecc, per privacy meglio evitare.
Se vuoi puliscilo e ricaricalo.
L'ho ricaricato solo col primo foglio nel quale ho inserito una colonna all'inizio e con =VALORE(B1), ecc. ho trasformato i tuoi giorni da testo in numero, poi ho selezionato questa colonna, l'ho copiata ed incollata su se stessa con Incolla speciale -> numeri.
Il problema è che i dati inseriti erano testo e non valori.
Per il formato della cella ti conviene usare Numero ed impostare l'opzione Zeri Iniziali a 2, così avrai sempre un numero di 2 cifre.

Immagine gravatar per akurery akurery ( 2020-02-12 17:29:34 +0100 )modifica
0

risposto il 2020-02-12 18:38:08 +0100

updated 2020-02-12 18:39:07 +0100

Ciao @Marta2912, dai numeri di importazione sono formattati come testo. Formato, numeri di codice 00 (zero zero).

Deve esserci dello "sporco" sul foglio di calcolo.

-----------------------------------------------------------------------------

ATTENZIONE: Se desideri fornire maggiori dettagli alla tua domanda, utilizza modifica in questione o aggiungi un commento di seguito. Grateful.

Se la risposta soddisfa le tue necessità, fai clic sulla palla Descrição da imagem a sinistra della risposta, per finire la domanda.

modifica flag offensive delete link more
0

risposto il 2020-02-09 00:00:00 +0100

Immagine gravatar per akurery

Visto che stai lavorando con delle date e fai vedere solamente la parte relativa al giorno, il formato dovrebbe essere GG (o DD in inglese) e non WW; quello fa vedere il numero della settimana nell'anno.
Se imposti il formato di data GG/MM/AAAA che cosa visualizza?
É probabile che siano giorni di mesi e anni differenti e che, tenendo conto di quelli (che con il formato sono solo nascosti), l'ordinamento fatto dal programma sarebbe corretto.
Prova ad inserire una colonna prima della A e impostare nella nuova cella A9 la formula =GIORNO(B9), poi copia la formula su tutta la colonna, quindi prova a riordinare in base a questa colonna di prova e vedi cosa succede.

modifica flag offensive delete link more

Commenti

Lavoro solo con il numero del giorno. Cioè io inserisco solo 01, 02, 13, 31, non inserisco proprio mese e anno e non li devo inserire. E sono giorni di uno stesso mese, ogni mese un file. Un foglio per ogni banca e un foglio riepilogativo con tutti i movimenti di tute le banche. Il problema viene fuori nel foglio riepilogativo, alcune date non vengono messi in ordine con le altre ma creano un ordine a parte.

Appena riesco allego il file. ods come richiesto. Grazie

Immagine gravatar per Marta2912 Marta2912 ( 2020-02-12 09:23:38 +0100 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2020-02-07 11:41:33 +0100

Seen: 31 times

Last updated: Feb 12