Fai la tua domanda
0

Conta celle non uguali

chiesto il 2020-05-21 16:20:50 +0200

Immagine gravatar per Wishmaster

updated 2020-05-21 16:21:34 +0200

Salve, volevo sapere se esiste una formula che mi conta ogni qualvolta la cella non è uguale. Mi spiego meglio, in una colonna io ho 3 volte ripetuto 4848 quando passo al valore 5050 lui mi deve contare 2 nonostante possono essere anche 3 celle per il primo valore e 10 per il secondo e via via, ovvero non mi devo fermare a due valori ma e una lista lunghissima e devo fare una somma totale si può fare? Spero di essermi spiegato bene. Scusate ancora per il disturbo e grazie.

modifica retag flag offensive close merge delete

Commenti

Salve! Allega un file d'esempio col risultato voluto messo a mano.

Immagine gravatar per gioh66 gioh66 ( 2020-05-21 19:59:51 +0200 )modifica

3 Answers

0

risposto il 2020-05-22 19:26:31 +0200

Immagine gravatar per akurery

updated 2020-05-22 19:27:42 +0200

In effetti la domanda non è chiara, ma sembra che tu voglia contare il numero di valori univoci, il che si può ottenere annidando CONTA.SE in MATR.SOMMA.PRODOTTO come segue:

=MATR.SOMMA.PRODOTTO(1/CONTA.SE(A1:A10;A1:A10&""))

Se invece non è questo che vuoi, prova a riformulare la domanda.

modifica flag offensive delete link more
0

risposto il 2020-05-22 12:12:28 +0200

Immagine gravatar per R.C.

Anch'io trovo non molto chiara la tua esposizione: in particolare, cosa intendi per "devo fare una somma totale"?

Per quanto ne ho capito, il tuo primo problema è contare quanti diversi valori hai, prescindendo dal fatto che 4848 ricorra tre volte nell'elenco, 5050 dieci, e così via. Se è così, penso che la soluzione più semplice sia impostare una tabella pivot, mettendo nel campo righe la colonna dove hai questi valori: otterrai tante righe quanti sono i diversi valori che ricorrono nel tuo elenco (e se ti servono altre elaborazioni la tabella te le fornirà).

CONTA.SE ti dice che 4848 ricorre tre volte e 5050 dieci, ma te lo dice ogni volta che li trova (a meno di non combinarla con altre funzioni ed opportuni accorgimenti), quindi non mi pare possa esserti immediatamente risolutiva.

Se la mia risposta ti ha aiutato, votala con ✔ (qui a sinistra)

modifica flag offensive delete link more
0

risposto il 2020-05-22 11:10:30 +0200

Immagine gravatar per Claudio R.

non è molto chiaro, tuttavia forse potrebbe esserti utile la funzione CONTA.SE

modifica flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2020-05-21 16:20:50 +0200

Seen: 18 times

Last updated: May 22