質問する
0

縦書き時の半角での空白

質問日 2020-03-16 15:25:27 +0200

aki のGravatar画像

updated 2020-03-19 05:22:45 +0200

nogajun のGravatar画像

縦書きで文章を書いていて縦中横の形にしたいのですが、半角で入力すると上に空白ができてしまいます。これを詰めるにはどうしたらいいのでしょうか?

全角入力  半角+90°

追記 回答ありがとうございます。 環境情報とサンプルデータです。サンプル

バージョン: 5.4.5.1 (x64) Build ID: 79c9829dd5d8054ec39a82dc51cd9eff340dbee8  CPU threads: 2; OS: Windows 6.19; UI render: GL; ロケール: ja-JP (ja_JP); Calc: group

フォントはHG明朝B あと本文の文章は直接打ったものではなく、小説投稿サイトからコピーしてきたものを貼り付けた感じです。

edit retag flag offensive close merge delete

Comments

  • バージョン: 7.0.0.0.alpha0+ (x64)
  • Build ID: 5dcbd1bb557450a2d658a710c163b310c0cee157
  • CPU threads: 4;
  • OS:Windows 10.0 Build 18363;
  • UI render: default;
  • VCL: win;
  • ロケール: ja-JP (ja_JP);
  • UIの言語: ja-JP
  • Calc: CL

再現しない

himajin100000 のGravatar画像himajin100000 ( 2020-03-16 17:38:43 +0200 )edit

バージョンは以下です。同じように作ってみましたが空白はできないですね。サンプル tatechuyoko.odt

バージョン: 6.4.1.2
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 8; OS:Linux 5.4; UI render: default; VCL: gtk3; 
ロケール: ja-JP (ja_JP.UTF-8); UIの言語: ja-JP
Calc: threaded

環境や段落スタイル、ページスタイルなどが書かれていないので、サンプルファイルをアップロードしてもらうか、どう設定したか書いていただけないでしょうか?

nogajun のGravatar画像nogajun ( 2020-03-17 05:45:45 +0200 )edit

再現しませんでした。
使用しているフォントは何でしょうか?

バージョン: 6.4.1.2 (x64)
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 4; OS:Windows 10.0 Build 18363; UI render: default; VCL: win;
ロケール: ja-JP (ja_JP); UIの言語: ja-JP
Calc: CL

hibagonsan のGravatar画像hibagonsan ( 2020-03-17 08:20:14 +0200 )edit

[段落の書式]→[配置]タブ→[オプション]→[罫線で位置合わせ]

この機能が本来何のためにあるかは知らない(汗

本コメント内強調は「スタイル側ではなく、少なくとも書式側を見ないといけない」という注意喚起

himajin100000 のGravatar画像himajin100000 ( 2020-03-17 16:09:23 +0200 )edit

hibagonsan氏の修正方法の方が俺の方法よりも適切。自分の場合、グリッド線を表示させると変な位置になっているのがよくわかる。

himajin100000 のGravatar画像himajin100000 ( 2020-03-18 07:22:15 +0200 )edit

2 Answer

2

回答日 2020-03-18 03:07:26 +0200

hibagonsan のGravatar画像

サンプルを拝見すると、ユーザーの独自の設定でページ設定のスタイル「本文ノーマル1奇数」、「本文ノーマル1偶数」と書式設定のスタイル「印刷用」が設定されていることが分かりました。この2種類の設定の作用で空白が表示されています。

「印刷用」スタイルをサイドバーで表示したところ。

画像の説明

この「印刷用」スタイルの設定を確認してみると、「位置」のタブで表示される設定において、ペアカーニングが「0.2pt」に設定されていました。「標準スタイル」ではこの値が「0.0pt」です。「0.0pt」に修正すると空白がなくなりました。

画像の説明

また、再現する場合には、ページ設定の「行数と文字数」のタブで、「行数と文字数指定(グリッド)」にチェックを入れます。サンプルのユーザー設定ではチェックが入っていました。標準では「行数と文字数指定なし」となっているはずです。行数と文字数が指定されていたために強制的に空白が入ったと思われます。イメージとしては見えない方眼紙のようなもの。

画像の説明

edit flag offensive delete link もっと

Comments

「印刷用」のペアカーニングを0.0ptにすることで無事空白をなくすことが出来ました! どうしても直せなくて大変困っていたので助かりました。ありがとうございました。

aki のGravatar画像aki ( 2020-03-18 11:56:33 +0200 )edit
0

回答日 2020-03-17 03:54:44 +0200

So のGravatar画像

画像の例に限って言えば、縦中横ではなく全角文字の感嘆符疑問符⁉を使うのがいいかと思います。縦中横の空白を減らす方法は別の質問の回答にあるリンク先で説明されています。

edit flag offensive delete link もっと
ログイン/サインアップして回答する

質問ツール

2 followers

Stats

Asked: 2020-03-16 15:25:27 +0200

Seen: 65 times

Last updated: Mar 18