Pergunte aqui
0

Agrupar produtos no LibreOffice Calc

perguntadas 2018-09-15 21:33:40 +0100

imagem do gravatar de Aldo

Boa tarde, Tenho uma planilha conforme arquivo em anexo, onde na coluna A tem mais de 1.000.000 de registros, porém preciso filtrar os registros por colunas (Para melhor exemplificar, criei as colunas C, D, E), onde após remover os dados duplicados, criei as colunas com o nome dos registros e agora preciso filtrar somente os dados que contém os nomes das colunas. Alguém pode me dar uma luz?

C:\fakepath\planilha_aldo.png

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

0

respondidas 2018-09-15 23:07:24 +0100

Ola @Aldo, considerando a imagem, a fórmula em C2 =SE(ESQUERDA($A2;NÚM.CARACT(C$1))=C$1;$A2;"") é só copiar para as colunas do lado e replicar para baixo.

Segue arquivo do teste.

Também poderia ordenar ou usar Tabela dinâmica, tudo depende do que deseja obter como resultado.


Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

Obrigado @Gilberto Schiavinatto. Era exatamente o que queria. Me ajudou muito. E antes de fechar a pergunta, como ficaria no caso de ter de puxar os valores de outra planilha? Não usaria mais o ESQUERDA?

imagem do gravatar de AldoAldo ( 2018-09-16 21:50:37 +0100 )editar

@Aldo, como a fórmula tem como base a Coluna A, desta maneira não dá.

Palpitando sem ver o arquivo completo, a sugestão é unir os 2 arquivos em um terceiro.

Se enviar o arquivo, ( gilberto@schiavinatto.com ) talvez possa dar alguma sugestão melhor.

Obs: O arquivo esta com mais de 1 mi de registros já retirado as duplicatas ????

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2018-09-17 03:04:59 +0100 )editar

Boa noite @Gilberto Schiavinatto. Já te enviei as planilhas por e-mail. Fico no aguardo de sua resposta. Quanto as duplicatas, só foram retirados das colunas do Relatório e dos dados não. Maiores informações, no e-mail enviado. Sem mais e no aguardo.

imagem do gravatar de AldoAldo ( 2018-09-18 03:29:58 +0100 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2018-09-15 21:33:40 +0100

Lidas: 17 vezes

Última atualização: Sep 15