Pergunte aqui
0

Formula que retorne o ultimo, penultimo, antepenultimo valor e etc

perguntadas 2019-06-19 22:50:40 +0200

updated 2019-06-24 21:23:49 +0200

Olá pessoal! Desde já, obrigado!

Eu gostaria de uma formula que fizesse o seguinte:

São 10 linhas

  1. Essa linha busca o ultimo valor de um intervalo
  2. Essa linha busca o penultimo valor de um intervalo
  3. Essa linha busca o antepenultimo valor de um intervalo
  4. Essa linha busca o 4º valor decrescente de um intervalo
  5. Essa linha busca o 5º valor decrescente de um intervalo
  6. Essa linha busca o 6º valor decrescente de um intervalo
  7. Essa linha busca o 7º valor decrescente de um intervalo
  8. Essa linha busca o 8º valor decrescente de um intervalo
  9. Essa linha busca o 9º valor decrescente de um intervalo
  10. Essa linha busca o 10º valor decrescente de um intervalo

Eu quero que a formula busque dentro de um intervalo em uma coluna!

O intervalo sempre será o mesmo.

No caso na minha planilha o intervalo é $'Histórico de Ordens'.C9:C10000

Eu até encontrei essa formula: =PROC(2;1/($'Histórico de Ordens'.C9:C10000>0);$'Histórico de Ordens'.C9:C10000) Mas ela só me da o ultimo valor, não consegui fazer encontrar o penultimo e nem os demais.

Obs: Alguns valores são texto, então a formula precisa buscar texto também!

Complemento

Assim deu amigo!

Mas sinceramente, eu queria isso sem ter que numerar as linhas!

Um amigo meu me disse, que com INDICE ou DESLOC dá pra fazer!

Mas eu ainda não conheço muito bem essas duas funções!

Será que você conseguiria reproduzir isso aí sem ter que numerar? O resultado é esse aí mesmo que eu quero!

Aguardo resposta!

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

@rafaBrunnoS, , NÃO USE Adicionar resposta, para comentários.....

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-20 02:03:15 +0200 )editar

Desculpa, sou novo no site, não sabia que havia diferença!

imagem do gravatar de faelBrunnoSfaelBrunnoS ( 2019-06-20 03:39:25 +0200 )editar

1 Resposta

1

respondidas 2019-06-20 00:26:18 +0200

updated 2019-06-20 02:28:02 +0200

Ola @rafaBrunnoS, veja se e isso:

Usei uma coluna para numerar os itens.

Descrição da imagem

Arquivo do teste

Se entendi errado, poste um arquivo exemplo.

Complemento

No arquivo que postei na célula E9 use a formula:

=ÍNDICE($B$9:$C$29;CONT.VALORES($B$9:$B$29)-(LINHA()-9);1)

e araste para baixo.


ATENÇÂO:: Caso queira dar mais detalhes a sua pergunta, use Descrição da imagem na pergunta ou Descrição da imagem abaixo. Grato.

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

Agora deu 100% Só que aparece um erro 505 quando não tem 10 celulas preenchidas! E no final fica com erro 505! Se houver alguma maneira de mostrar 0 ao invés do erro, fico grato! Se não, eu faço dela uma formula fantasma e uso função SE mesmo!

imagem do gravatar de faelBrunnoSfaelBrunnoS ( 2019-06-20 03:43:08 +0200 )editar

=SEERRO(ÍNDICE($B$9:$C$29;CONT.VALORES($B$9:$B$29)-(LINHA()-9);1);0) mostra 0

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-20 04:42:49 +0200 )editar

Pronto, agora ficou perfeito amigo! Muito obrigado! 3ª vez que você me ajuda já! Obrigado!

Posso entrar em contato aqui? Tenho uma pequena duvida sobre uma outra pergunta que fiz!

imagem do gravatar de faelBrunnoSfaelBrunnoS ( 2019-06-20 05:10:45 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-06-19 22:50:40 +0200

Lidas: 31 vezes

Última atualização: Jun 20