Pergunte aqui
0

Cálculo de prazo, se cair em final de semana estender até o próximo dia útil

perguntadas 2019-06-26 13:54:39 +0200

imagem do gravatar de Rodrigo Zimmermann

updated 2019-06-29 19:22:40 +0200

Preciso montar uma fórmula que faça o seguinte:^

=se (data + 14 dias) cair no sábado, então (data + 16 dias), se cair no domingo, então (data + 15 dias), caso contrário (data + 14 dias).

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

0

respondidas 2019-06-26 15:10:34 +0200

@Rodrigo Zimmermann, uma solução:

=SE(DIA.DA.SEMANA(F20)=7;F20+2;SE(DIA.DA.SEMANA(F20)=1;F20+1;F20))

Considerando a data em F20.

-----------------------------------------------------------------------------

ATENÇÂO:: Caso queira dar mais detalhes a sua pergunta, use Descrição da imagem na pergunta ou Descrição da imagem abaixo. Grato.

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

É exatamente o que eu precisava.

imagem do gravatar de Rodrigo ZimmermannRodrigo Zimmermann ( 2019-06-28 18:03:56 +0200 )editar
1

respondidas 2019-06-26 19:36:08 +0200

imagem do gravatar de Conrado

@Rodrigo Zimmermann,

Pode utilizar também a seguinte função do Calc

=DIATRABALHO(DataInicial, Dias(seu exemplo 14))

Exemplo:

DataInicial (A1) = 26/06/2019

Dias (A2) = 14

A3 = DIATRABALHO(A1, A2)

A3 = 16/07/2019 (precisa formatar a célula como data, caso contrário retorna o resultado em modo numérico)

Com essa função, todos os sábados e domingos são desconsiderados. Pode ser criado também uma lista com os feriados, e acrescentado a Função =DIATRABALHO(DataInicial, Dia, Feriados). Dessa forma também será desconsiderado as datas de feriados no cálculo.

Segue uma planilha para explicar melhor como funciona.

Arquivo

editar assinalar como ofensivo Excluir Link mais

Comentários

O cálculo de prazo que preciso não é de dias úteis, são dias corridos mas o prazo é estendido se o último dia do prazo cair num sábado ou domingo.

imagem do gravatar de Rodrigo ZimmermannRodrigo Zimmermann ( 2019-06-28 18:04:53 +0200 )editar

@Rodrigo Zimmermann,

Neste caso é só não colocar a tabela de feriado. Como mencionei na primeira fórmula

imagem do gravatar de ConradoConrado ( 2019-06-28 19:15:01 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-06-26 13:54:39 +0200

Lidas: 15 vezes

Última atualização: Jun 26