Pergunte aqui
1

Fórmula com um intervalo flutuante e soma

perguntadas 2020-01-08 03:23:33 +0100

imagem do gravatar de kcg

updated 2020-01-12 15:39:59 +0100

imagem do gravatar de Schiavinatto

Prezados, fiz uma planilha em que há uma linha com vários horários (ex: 13:01, 13:02, ..., 17:00) e embaixo de cada horário é colocado o número 1 se houver vaga para agendamento. Para controlar a quantidade de vagas para agendamento, fiz uma nova planilha com a hora inicial, a hora final e um intervalo de tempo (ex: hora inicial 13:00, hora final 13:10 se o intervalo for de 10 min), sendo que este último pode variar. A intenção é saber quantas senhas foram agendadas parra aquele intervalo, contudo não consigo fazer uma fórmula que leve em consideração o intervalo entre a Hora inicial e a hora final e some a qtde de senhas dentro deste intervalo. Alguém poderia me ajudar?

Complemento

Anexei a planilha em que estou tentando trabalhar. Na aba "Problemas" descrevo os dois problemas que estou enfrentado. Desde já agradeço a todos que puderem me ajudar.C:\fakepath\Planilha - Matriz de agendamento.ods. Schiavinatto, obrigado pela dica de como anexar a planilha aqui. Conrado, obrigado pela dica do somase o qual já estou usando.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Ola @kcg, seja bem vindo ao Grupo.

De um exemplo de como esta esta planilha, edite sua pergunta e use o ícone clipe para anexar o arquivo exemplo...

imagem do gravatar de SchiavinattoSchiavinatto ( 2020-01-08 12:53:06 +0100 )editar

2 Respostas

0

respondidas 2020-01-12 17:54:03 +0100

imagem do gravatar de Schiavinatto

@kcg, segue planilha alterada:

.

Alterações:

  • Na planilha MATRIZ
  • em D1 =00:01:00 ( formatado hora )
  • em E2 formula =D2+$D$1
  • e repliquei para a direita
  • limpei a linha 11, não é necessária
  • em C18 formula =SOMASES($D$10:$IK$10;$D$2:$IK$2;">="&A18;$D$2:$IK$2;"<="&B18)
  • e repliquei para baixo

-----------------------------------------------------------------------------

ATENÇÂO:: Para dar mais detalhes a sua pergunta, use Descrição da imagem na pergunta ou Descrição da imagem abaixo. Não use Adicionar resposta para comentário. Grato.

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2020-01-08 15:55:56 +0100

imagem do gravatar de Conrado

@kcg seria isso que você precisa?

Função SOMASES

Arquivo Teste

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2020-01-08 03:23:33 +0100

Lidas: 41 vezes

Última atualização: Jan 12