Pergunte aqui
0

Função CONCAT sem repetir números iguais

perguntadas 2020-09-25 18:39:31 +0200

imagem do gravatar de TheoKieck

updated 2020-10-07 13:26:18 +0200

imagem do gravatar de Schiavinatto

Sou coordenador de uma escola pública e estou tentando construir uma planilha no Calc que sintetize algumas informações como notas, faltas e observações dos professores. Os professores preenchem uma tabela com números de 1 a 6 (cada número tem uma legenda para um problema específico "Falta de Interesse", por ex), eu copio essa tabela para minha planilha e as informações ficam linkadas por toda a planilha.

Meu problema é que uma das coisas que quero criar é uma planilha ATA com o resumo das informações e não estou conseguindo otimizar a função CONCAT. Vários professores inserem os códigos (de 1 a 6) e eu gostaria que na planilha ATA o resultado apresentasse esses números sem repetição, como se a função CONCAT excluísse números repetidos. Exemplo: Matemática: |1|3|5| / Português: |1|2|5| / Física: |2|3|5| -> Resultado função CONCAT=135125235 -> Resultado que preciso=1235

Da mesma maneira existe um campo "Ações" com ações A,B,C,D. Gostaria que na ATA eles tbm saíssem sem repetição, mas acredito que o procedimento é o mesmo. Segue um print da planilha em que os professores inserem os códigos e a ATA.

Agradeço imensamente se puderem me ajudar, já são horas de trabalho que vão ajudar muito na organização da escola Abraços! PrintTABELA PrintATA

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

0

respondidas 2020-09-25 20:18:14 +0200

imagem do gravatar de Schiavinatto

@TheoKieck, veja se te atende:

Descrição da imagem

Para a situação acima a formula é:

=SE(CONT.SE($B$4:$K$4;1)>0;1;"")&SE(CONT.SE($B$4:$K$4;2)>0;2;"")&SE(CONT.SE($B$4:$K$4;3)>0;3;"")&SE(CONT.SE($B$4:$K$4;4)>0;4;"")&SE(CONT.SE($B$4:$K$4;5)>0;5;"")

-----------------------------------------------------------------------------

ATENÇÂO:: Para dar mais detalhes a sua pergunta, use Descrição da imagem na pergunta ou Descrição da imagem abaixo. Não use Adicionar resposta para comentário. Grato.

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

Schiavinatto, muito obrigado. Vou verificar aqui se me atende. Pensei mesmo numa colução com SE, mas me perdi na construção. Em breve respondo! Abraços!

imagem do gravatar de TheoKieckTheoKieck ( 2020-09-28 22:40:01 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2020-09-25 18:39:31 +0200

Lidas: 30 vezes

Última atualização: Sep 25 '20