Pergunte aqui
0

Como separar em abas diferentes lista ordenada?

perguntadas 2016-02-17 03:07:10 +0100

imagem do gravatar de Robbie Dean

Tenho uma planilha com diversos nomes, de A a Z, ordenados alfabeticamente.

Preciso copiar para outra aba os nomes separadamente baseado na primeira letra, por exemplo: numa planilha terei os nomes que começam com A, noutra os que começam com B e assim por diante.

Tentei resolver com fórmula, mas não consegui... Alguém saberia me dizer como resolver isso com fórmula ou com Macro?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

0

respondidas 2016-02-18 19:40:55 +0100

imagem do gravatar de Beto

updated 2016-02-24 16:03:27 +0100

Cria mais uma coluna e coloque ao lado a fórmula =ESQUERDA(A1;1) por exemplo. Pegará a primeira letra da coluna Linha 1 da coluna A (do nome) e assim ficará mais fácil para você fazer o filtragem. Depois Vá em Dados e escolha Filtro padrão use como critério a inicial separada pela forma, clique no sinal de + e escolha para qual planilha os dados irão. Olhe as figuras. Descrição da imagem Descrição da imagem

Outra maneira e usar a fórmula SE() nas demais planilhas: =SE(Planilha1.B1="A";Planilha1.A1). Arraste para baixo até o total presumido de linhas. olhe a figura:

Descrição da imagem

Caso queira um exemplo para olhar faça o download desse arquivo e observe as planilhas 1, 2 e 3 onde estão os exemplos. Tabela Dinâmica- filtragem pelas iniciais.ods

São dois jeitos que encontrei pelas vias "normais", já que macro não é minha praia.

Obs: Caso você opte pela fórmula, você pode dispensar a criação da coluna (para criação de iniciais) e colocar direto a seguinte fórmula: =SE(Planilha1.B1=(ESQUERDA(Planilha1.A1;1));Planilha1.A1).

editar assinalar como ofensivo Excluir Link mais

Comentários

Muito obrigado, Beto. É quase isso que quero. Eu já havia tentando alguma coisa similar, no entanto, quando adicionei um novo nome a lista, ele não apareceu automaticamente do outro lado.

imagem do gravatar de Robbie DeanRobbie Dean ( 2016-02-23 02:23:29 +0100 )editar

Não entendi o que você fez... talvez se você explicasse um pouco mais seu projeto. No entanto vou sugeri que use o recurso a tabela dinâmica do Calc para isso. Dá muito certo, depende para que quer, logicamente. Vou substituir o arquivo com o exemplo na minha resposta. Baixe-o de novo. Saiba mais sobre a tabela dinâmica. Aqui

imagem do gravatar de BetoBeto ( 2016-02-24 15:19:51 +0100 )editar

O resultado da tabela dinâmica foi bem melhor. Obrigado!

imagem do gravatar de Robbie DeanRobbie Dean ( 2016-02-25 01:00:52 +0100 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2016-02-17 03:07:10 +0100

Lidas: 778 vezes

Última atualização: Feb 24 '16